Author paul.moore
Recipients barry, paul.moore
Date 2013-10-21.14:18:29
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1382365110.02.0.716566068981.issue19331@psf.upfronthosting.co.za>
In-reply-to
Content
How about simply adding a further sentence, something like:

"Where a class is being used conceptually as a callable (for example, context managers), the naming convention for callables (lower_case_with_underscores) should be followed."

Maybe also add a section at the start of "Naming Conventions":

"""
Overriding Principle
Whenever names are visible to the user, as public parts of the API, the naming convention should reflect usage rather than implementation. An internal change (for example switching from a class to a factory function) should never affect the names used in the public API.
"""
History
Date User Action Args
2013-10-21 14:18:30paul.mooresetrecipients: + paul.moore, barry
2013-10-21 14:18:30paul.mooresetmessageid: <1382365110.02.0.716566068981.issue19331@psf.upfronthosting.co.za>
2013-10-21 14:18:29paul.moorelinkissue19331 messages
2013-10-21 14:18:29paul.moorecreate