Author tim.peters
Recipients hynek, loewis, lukasz.langa, mark.dickinson, ncoghlan, r.david.murray, rhettinger, serhiy.storchaka, tim.peters
Date 2013-08-04.21:25:26
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
FWIW, I like this.  It would be a nice addition to the itertools module. +1

The `key` argument should be renamed to `pred`, as others have said.

As to the name, I like "first_true".  Does what it says.  Plain "first" is misleading, and "coalesce" is both inscrutable and nearly impossible to spell ;-)
Date User Action Args
2013-08-04 21:25:26tim.peterssetrecipients: + tim.peters, loewis, rhettinger, mark.dickinson, ncoghlan, r.david.murray, lukasz.langa, hynek, serhiy.storchaka
2013-08-04 21:25:26tim.peterssetmessageid: <>
2013-08-04 21:25:26tim.peterslinkissue18652 messages
2013-08-04 21:25:26tim.peterscreate