Author serhiy.storchaka
Recipients benjamin.peterson, christian.heimes, docs@python, hynek, pitrou, serhiy.storchaka, stutzbach
Date 2013-01-20.17:19:45
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Here is a patch which changes name of optional parameter of read(), read1(), peek(), and readline() methods to most common name "size" in the documentation and _pyio module. truncate() in _pyio fixed to conform with documentation. This changes are safe.

There is open question about readlines(). It's optional parameter named as:

"hint" in _pyio and the documentation;
"size" in bz2;
"sizehint" in codecs and mailbox.
Date User Action Args
2013-01-20 17:19:48serhiy.storchakasetrecipients: + serhiy.storchaka, pitrou, christian.heimes, benjamin.peterson, stutzbach, docs@python, hynek
2013-01-20 17:19:47serhiy.storchakasetmessageid: <>
2013-01-20 17:19:47serhiy.storchakalinkissue17003 messages
2013-01-20 17:19:45serhiy.storchakacreate