Author vstinner
Recipients ezio.melotti, serhiy.storchaka, vstinner
Date 2012-12-24.16:03:57
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1356365038.2.0.0934469716104.issue16757@psf.upfronthosting.co.za>
In-reply-to
Content
Avoid scanning a substring to compute the maximum character is a good thing, so +1 for the idea. Instead of modifying an existing function, it might be safer to rename it. Even if it is private, a third party module *can* use it outside Python. It is also surprising that you have to specifiy a "maxchar" argument whereas the purpose of the function is to compute the maximum character.

Ex: rename _PyUnicode_FindMaxChar() to _PyUnicode_FindMaxChar2(), and add _PyUnicode_FindMaxChar() as the macro:

#define _PyUnicode_FindMaxChar(str, start, length) _PyUnicode_FindMaxChar2(str, start, length, 127)
History
Date User Action Args
2012-12-24 16:03:58vstinnersetrecipients: + vstinner, ezio.melotti, serhiy.storchaka
2012-12-24 16:03:58vstinnersetmessageid: <1356365038.2.0.0934469716104.issue16757@psf.upfronthosting.co.za>
2012-12-24 16:03:58vstinnerlinkissue16757 messages
2012-12-24 16:03:57vstinnercreate