Author pitrou
Recipients Arfrever, amaury.forgeotdarc, denilsonsa, eric.araujo, giampaolo.rodola, loewis, neologix, pitrou, rosslagerwall, vstinner, zbysz
Date 2012-01-21.22:47:26
SpamBayes Score 9.45742e-09
Marked as misclassified No
Message-id <1327185929.3382.30.camel@localhost.localdomain>
In-reply-to <1327174819.2.0.625826601057.issue13609@psf.upfronthosting.co.za>
Content
> +1. I also find weird that a function, especially one living in the os
> module, has such a high level of abstraction (basically this is why I
> was originally proposing shutil module for this to go in).
> 
> Given the different opinions about the API, I think it's best to
> expose the lowest level functionality as-is, and let the user decide
> what to do (read env vars first, suppress the exception, use a
> fallback, etc.). 

Fair enough, but other people expressed sympathy for the two-function
approach :) I'm personally indifferent, although I find
"get_terminal_size_raw" a bit ugly and liked "query_terminal_size"
better.

(and looking up ROWS and COLUMNS make sense, since they are de facto
standards)
History
Date User Action Args
2012-01-21 22:47:28pitrousetrecipients: + pitrou, loewis, amaury.forgeotdarc, vstinner, giampaolo.rodola, eric.araujo, Arfrever, zbysz, denilsonsa, neologix, rosslagerwall
2012-01-21 22:47:26pitroulinkissue13609 messages
2012-01-21 22:47:26pitroucreate