Author eric.araujo
Recipients alexis, eric.araujo, jaraco, tarek
Date 2012-01-06.16:33:18
SpamBayes Score 8.31707e-12
Marked as misclassified No
Message-id <1325867599.23.0.41298167243.issue11473@psf.upfronthosting.co.za>
In-reply-to
Content
This is a strange bug.  I added a test using -r server2, using the already-existing PYPIRC_LONG_PASSWORD string as .pypirc contents.  The test passes.  To make sure changing one test would not affect another one, I created a new .pypirc file, PYPIRC_CUSTOM_SERVER, and then I got to see your bug!  I tried various combinations of keys (realm or not, user or not), changed the markup (: or = as delimiter, spaces or not) but could not easily find the root of the bug.

Can you publish a .pypirc file that works with 2.7 and not with 3.2?  That would be a good starting point.

msg144569 - (view) 	Author: Jason R. Coombs (jason.coombs) * (Python committer) 	Date: 2011-09-28 18:09

I now seem to be unable to reproduce the issue. I do keep my .pypirc in a revision control system, so I have reasonable confidence that my .pypirc contained the content that I'm attaching now (passwords scrubbed of course).

> One possible factor is that my .pypirc is symlinked from ~/.pypirc to config/python/.pypirc and
> it's conceivable that Python 3.2.0 has some issues with symlink resolution that caused it to not
> process the .pypirc properly.

Are these Windows symlinks?  Are they supposed to be dereferenced transparently by the OS (i.e. during open) like unix symlinks?

> Sure enough. I just confirmed that with Python 3.2.0, if .pypirc is symlinked, distutils behaves
> as if the .pypirc isn't present at all, but if that same .pypirc is copied, it behaves as
> expected. If one deletes the .pypirc altogether, it produces the same error.

OK.  For distutils2, I think we’ll want better logging/error reporting.  The user should see “no /what/ever/.pypirc found”, not “section not found”.

> I suggest we mark this bug as resolved (as the primary cause was due to the file not being read at
> all), but also apply your patch (which has some other good fixes) without the CUSTOM_SERVER, or
> with a version of the CUSTOM_SERVER that works.

Agreed.  I’ll resume work on that patch to understand why it fails.
History
Date User Action Args
2012-01-06 16:49:55eric.araujounlinkissue11473 messages
2012-01-06 16:33:19eric.araujosetrecipients: + eric.araujo, jaraco, tarek, alexis
2012-01-06 16:33:19eric.araujosetmessageid: <1325867599.23.0.41298167243.issue11473@psf.upfronthosting.co.za>
2012-01-06 16:33:18eric.araujolinkissue11473 messages
2012-01-06 16:33:18eric.araujocreate