Author rhettinger
Recipients Alexander.Belopolsky, Arfrever, belopolsky, jcea, khenriksson, larry, lars.gustaebel, loewis, mark.dickinson, nadeem.vawda, r.david.murray, rhettinger, rosslagerwall, skrah, vstinner
Date 2011-10-09.15:20:06
SpamBayes Score 9.12989e-05
Marked as misclassified No
Message-id <>
[Arfrever Frehtes Taifersar Arahesis]
> I suggest to have low-level, POSIX-compatible, 
> (int, int)-based interface in os module and add 
> high-level, decimal.Decimal-based interface in 
> shutil module.

I agree that this is the cleanest approach.
Ideally, the os module stays as close as possible
to the underlying structures.  Also, it is desirable
to keep it fast (not importing a pure python decimal
module as a side-effect of checking the a timestamp
-- making everyone pay the cost for a feature that
few people will want or need).

With respect to the options suggested by MvL,
I support adding new named fields and opposed
to using a flag to indicate a type change (that
would be error-prone).

If new fields as added, their names need to follow
the existing naming convention (st_variable).

-1 on the patch as currently proposed.  I don't
think the performance impact is acceptable.
Date User Action Args
2011-10-09 15:20:07rhettingersetrecipients: + rhettinger, loewis, jcea, mark.dickinson, belopolsky, lars.gustaebel, vstinner, larry, nadeem.vawda, Arfrever, r.david.murray, skrah, Alexander.Belopolsky, rosslagerwall, khenriksson
2011-10-09 15:20:07rhettingersetmessageid: <>
2011-10-09 15:20:06rhettingerlinkissue11457 messages
2011-10-09 15:20:06rhettingercreate