Author zegreek
Recipients eric.araujo, nils, tarek, vstinner, zegreek
Date 2011-05-13.13:11:57
SpamBayes Score 1.53477e-11
Marked as misclassified No
Message-id <4DCD2DD2.1020503@free.fr>
In-reply-to <1305068684.08.0.750782613492.issue6011@psf.upfronthosting.co.za>
Content
Indeed, I retried with 534a9e274d88 (that was the tip of 3.2 sometime 
yesterday) and my original problem is solved. Thank you.

While I was at it, I ran "make test",  and got 3 unusual skips and 1 
failure.

The skips are test_sax, test_xml_etree and test_xml_etree_c and they are 
skipped on purpose when the example XML filename is not encodable to 
utf8. No problem here.

The failure is for test_distutils. 3 individual tests are failing: 
test_simple_built, test_debug_mode and test_record. The cause of this 
failure is that the "install" command installs a test distribution to a 
path containing sys.prefix. This is not a problem per se, but later 
test_simple_built tries to zip this distribution, and cannot construct a 
valid archive name. A similar problem happens when test_record tries to 
write the distribution's filenames to a record file (and test_debug_mode 
fails because of test_record).

Imho those failures cannot be fixed, so the only possible improvement is 
to skip those tests. The attached trivial patch does just that, but I'm 
not sure if it's worth patching distutils for that.

Cheers,
Baptiste
Files
File name Uploaded
test_distutils_surrogateescape.diff zegreek, 2011-05-13.13:11:57
History
Date User Action Args
2011-05-13 13:11:58zegreeksetrecipients: + zegreek, vstinner, tarek, eric.araujo, nils
2011-05-13 13:11:57zegreeklinkissue6011 messages
2011-05-13 13:11:57zegreekcreate