Author pitrou
Recipients benjamin.peterson, db3l, gregory.p.smith, neologix, pitrou, python-dev, rnk, sable, vstinner
Date 2011-04-26.17:43:09
SpamBayes Score 1.55032e-10
Marked as misclassified No
Message-id <1303839779.3518.66.camel@localhost.localdomain>
In-reply-to <1303781690.30079.2.camel@marge>
Content
Le mardi 26 avril 2011 à 01:34 +0000, STINNER Victor a écrit :
> STINNER Victor <victor.stinner@haypocalc.com> added the comment:
> 
> > >  - Rename _PyThread_Info() to PyThread_GetInfo() (consistent name with
> > > PyFloat_GetInfo() and PyLong_GetInfo())
> > 
> > I don't think we want that API to be public, so it should be
> > _PyThread_GetInfo().
> 
> Why should it be private in C, but not in Python?

Well, if it's called _info() in Python, it's private too!

> > >  - Always compile thread.c, but add #ifdef WITH_THREAD around most the
> > > file (except PyThread_GetInfo())
> > 
> > What's the point? Sounds like pointless complication.
> 
> Complication? It does *simplify* configure.in.
> 
> I don't want to create a new file just for a small function.

What I mean is that the "#ifdef WITH_THREAD" could be done in
sysmodule.c rather than in thread.c

Also, when Python is compiled without threads, I don't think thread_info
should be a structseq. It should probably be None instead.

Another small thing: your doc says "name" is optional, but it shouldn't.
History
Date User Action Args
2011-04-26 17:43:09pitrousetrecipients: + pitrou, gregory.p.smith, db3l, vstinner, sable, benjamin.peterson, rnk, neologix, python-dev
2011-04-26 17:43:09pitroulinkissue11223 messages
2011-04-26 17:43:09pitroucreate