Author pitrou
Recipients benjamin.peterson, db3l, gregory.p.smith, neologix, pitrou, python-dev, rnk, sable, vstinner
Date 2011-04-20.23:20:24
SpamBayes Score 2.38281e-05
Marked as misclassified No
Message-id <1303341621.3493.5.camel@localhost.localdomain>
In-reply-to <1303341322.01.0.722397594727.issue11223@psf.upfronthosting.co.za>
Content
>  - Rename _PyThread_Info() to PyThread_GetInfo() (consistent name with
> PyFloat_GetInfo() and PyLong_GetInfo())

I don't think we want that API to be public, so it should be
_PyThread_GetInfo().

>  - Always compile thread.c, but add #ifdef WITH_THREAD around most the
> file (except PyThread_GetInfo())

What's the point? Sounds like pointless complication.
History
Date User Action Args
2011-04-20 23:20:25pitrousetrecipients: + pitrou, gregory.p.smith, db3l, vstinner, sable, benjamin.peterson, rnk, neologix, python-dev
2011-04-20 23:20:24pitroulinkissue11223 messages
2011-04-20 23:20:24pitroucreate