Author pitrou
Recipients db3l, gregory.p.smith, neologix, pitrou, python-dev, rnk, sable, vstinner
Date 2011-04-19.21:27:33
SpamBayes Score 3.75377e-07
Marked as misclassified No
Message-id <1303248451.3741.4.camel@localhost.localdomain>
In-reply-to <1303247977.21240.15.camel@marge>
Content
> I also renamed 'name' key to 'thread', so 'thread' is the name of the
> *thread* implementation, and 'lock' is the name of the *lock*
> implementation.

Not that I want to bikeshed, but I think 'name' was ok (since you get
the dict by calling threading._info(), it's obvious it has to do with
threading).
'lock_implementation' would be better than 'lock', OTOH.

Also, the 'pthread_version' documentation should state that it is
optional (only works on GNU).
History
Date User Action Args
2011-04-19 21:27:34pitrousetrecipients: + pitrou, gregory.p.smith, db3l, vstinner, sable, rnk, neologix, python-dev
2011-04-19 21:27:33pitroulinkissue11223 messages
2011-04-19 21:27:33pitroucreate