This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author santoso.wijaya
Recipients ned.deily, ronaldoussoren, santoso.wijaya
Date 2011-03-14.06:09:57
SpamBayes Score 1.6977942e-06
Marked as misclassified No
Message-id <>
> Running configure on a MacOSX system will set
> MACOSX_DEPLOYMENT_TARGET to 10.4, which is probably not optimal
> for anyone on a recentish system.

What's more, when I first tried to compile Python on Mac OS X, and I have MacPorts' version of Python as the default interpreter in the terminal, I get the following errors when trying to do bare `./configure; make`:

bash-3.2$ make 
./Parser/ -h ./Include ./Parser/Python.asdl
Traceback (most recent call last):
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 553, in <module>
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 535, in main
    known_paths = addusersitepackages(known_paths)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 268, in addusersitepackages
    user_site = getusersitepackages()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 243, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 233, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 535, in get_config_var
    return get_config_vars().get(name)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 434, in get_config_vars
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/", line 313, in _init_posix
    raise IOError(msg)
IOError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.4" but "10.6" during configure
make: *** [Include/Python-ast.h] Error 1

I worked around this by adding MACOSX_DEPLOYMENT_TARGET=10.6 to the configure script, but I have to remember to do that every time I configured a fresh clone of the source.
Date User Action Args
2011-03-14 06:09:58santoso.wijayasetrecipients: + santoso.wijaya, ronaldoussoren, ned.deily
2011-03-14 06:09:58santoso.wijayasetmessageid: <>
2011-03-14 06:09:57santoso.wijayalinkissue11485 messages
2011-03-14 06:09:57santoso.wijayacreate