Author belopolsky
Recipients Rhamphoryncus, amaury.forgeotdarc, belopolsky, eric.smith, ezio.melotti, lemburg, loewis, pitrou, rhettinger, vstinner
Date 2010-11-27.22:19:34
SpamBayes Score 0.000169424
Marked as misclassified No
Message-id <>
In-reply-to <>
On Sat, Nov 27, 2010 at 5:03 PM, Marc-Andre Lemburg
<> wrote:
>  * same for the Py_UNICODE_NEXT() macro, i.e. Py_UCS4_NEXT()
>  * in order to make the macro easier to understand, please rename it to
>  Py_UCS4_READ_CODE_POINT(); that's a little more typing, but still
>  a lot less than without the macro :-)

I am not sure Py_UCS4_ prefix is right here.  (I agree on *SURROGATE*
methods.)  The point of Py_UNICODE_NEXT(ptr, end) is that the pointers
ptr and end are Py_UNICODE* and the macro expands to *p++ on wide
builds.  Maybe Py_UNICODE_NEXT_USC4?
Date User Action Args
2010-11-27 22:19:41belopolskysetrecipients: + belopolsky, lemburg, loewis, rhettinger, amaury.forgeotdarc, Rhamphoryncus, pitrou, vstinner, eric.smith, ezio.melotti
2010-11-27 22:19:34belopolskylinkissue10542 messages
2010-11-27 22:19:34belopolskycreate