Author r.david.murray
Recipients brett.cannon, ezio.melotti, michael.foord, pitrou, r.david.murray, rhettinger
Date 2010-11-03.01:31:41
SpamBayes Score 2.09245e-09
Marked as misclassified No
Message-id <>
I don't think assertLE is enough of an improvement over assertLessEqual to be worth adding yet more deprecated names to unittest. So I'm -0 on this change in general.  (I'd be -1 except that it would be kind of nice to have the names be shorter :)

If the change is made, then assertEqual should become assertEQ, and assertNotEqual should become assertNE.

Another option is to go the other way, and change assertLess to assertLessThan.  That is, make the spelling consistently be the spelled out version of the abbreviation used in the special methods and elsewhere in the docs.  This would involve far fewer name changes.
Date User Action Args
2010-11-03 01:31:43r.david.murraysetrecipients: + r.david.murray, brett.cannon, rhettinger, pitrou, ezio.melotti, michael.foord
2010-11-03 01:31:43r.david.murraysetmessageid: <>
2010-11-03 01:31:42r.david.murraylinkissue10273 messages
2010-11-03 01:31:41r.david.murraycreate