classification
Title: multiprocessing problems
Type: Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: socket.setdefaulttimeout affecting multiprocessing Manager
View: 6056
Assigned To: jnoller Nosy List: hume, jnoller, neologix
Priority: normal Keywords:

Created on 2010-09-19 10:06 by hume, last changed 2011-11-01 14:27 by neologix. This issue is now closed.

Messages (4)
msg116854 - (view) Author: hume (hume) Date: 2010-09-19 10:06
when use multiprocessing managers, while use socket to communicate between server process and client process, if I used the global socket timeout feature(no matter how large the value is) the client will always say

  File "c:\python27\lib\multiprocessing\connection.py", line 149, in Client
    answer_challenge(c, authkey)
  File "c:\python27\lib\multiprocessing\connection.py", line 383, in answer_challenge
    message = connection.recv_bytes(256)         # reject large message
IOError: [Errno 10035] 

this is not reasonable, because this behaviour will make subprocess unable to use socket's timeout features globally.

Another question is line 138 in managers.py:
        # do authentication later
        self.listener = Listener(address=address, backlog=5)
        self.address = self.listener.address

backlog=5 will accept only 5 cocurrent connections, this is not so user friendly, you'd better make this a argument that can be specified by user
msg116877 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-09-19 16:34
hume; filing this again doesn't help. I closed issue 9851 as a duplicate of this for you.
msg116907 - (view) Author: hume (hume) Date: 2010-09-20 03:19
ok, I refill this to fix the un-plesant words problem.
msg146779 - (view) Author: Charles-François Natali (neologix) * (Python committer) Date: 2011-11-01 14:27
The first problem is a duplicate of issue #6056.

As for the second problem, no, it doesn't limit the number of concurrent connections. Server.serve_forever() creates a new thread for each new incoming connection.

Closing as duplicate.
History
Date User Action Args
2011-11-01 14:27:50neologixsetstatus: open -> closed

nosy: + neologix
messages: + msg146779

superseder: socket.setdefaulttimeout affecting multiprocessing Manager
resolution: duplicate
2010-09-20 03:19:02humesetmessages: + msg116907
2010-09-19 16:34:16jnollersetmessages: + msg116877
2010-09-19 14:46:35pitrousetassignee: jnoller

nosy: + jnoller
2010-09-19 10:06:29humecreate