classification
Title: distutil's build_scripts doesn't read utf-8 in all locales
Type: Stage: resolved
Components: Distutils, Distutils2 Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: distutils: set encoding to utf-8 for input and output files
View: 9561
Assigned To: tarek Nosy List: eric.araujo, hagen, tarek
Priority: normal Keywords:

Created on 2010-09-17 13:19 by hagen, last changed 2010-09-21 10:33 by eric.araujo. This issue is now closed.

Messages (4)
msg116660 - (view) Author: Hagen Fürstenau (hagen) Date: 2010-09-17 13:19
"LANG=C python3 setup.py build_scripts" chokes on UTF-8 encoded scripts. The problem is that "copy_scripts" uses "open" without specifying an encoding. This issue may be related to #9561.
msg116991 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-09-20 22:21
Does POSIX mandate an encoding when using the C locale?
msg117032 - (view) Author: Hagen Fürstenau (hagen) Date: 2010-09-21 06:51
Why does this matter? PEP 3120 specifies UTF-8 as the default source encoding.
msg117044 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-09-21 10:33
Okay.  Then this bug is part of #9561.
History
Date User Action Args
2010-09-21 10:33:34eric.araujosetstatus: open -> closed

superseder: distutils: set encoding to utf-8 for input and output files
components: + Distutils2
versions: + Python 2.7, Python 3.2
nosy: tarek, eric.araujo, hagen
messages: + msg117044
resolution: duplicate
stage: resolved
2010-09-21 06:51:20hagensetmessages: + msg117032
2010-09-20 22:21:28eric.araujosetmessages: + msg116991
2010-09-17 13:19:51hagencreate