classification
Title: Message.attach() loses empty attachments
Type: behavior Stage: resolved
Components: email Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: barry, r.david.murray, raph@mankin.org.uk
Priority: normal Keywords:

Created on 2010-09-16 13:53 by raph@mankin.org.uk, last changed 2013-02-11 15:28 by r.david.murray. This issue is now closed.

Messages (6)
msg116550 - (view) Author: Raphael Mankin (raph@mankin.org.uk) Date: 2010-09-16 13:53
When attaching a sequence of parts to a MIMEMultipart message, empty attachments are silently discarded.
msg116551 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-09-16 13:58
Can you provide a simple example program that demonstrates the problem?
msg116559 - (view) Author: Raphael Mankin (raph@mankin.org.uk) Date: 2010-09-16 15:14
'Simple' is the problem. I will come back to you on this.
msg116569 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-09-16 16:12
Got your off-ticket email.  I was hoping for something that *just* demonstrated the problem (just enough code to show the issue).  It may be a bit before I can find the time to reduce your code to such a test case.
msg161475 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-05-24 03:05
And now it's been long enough that I lost the email :(
msg181900 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-02-11 15:28
Lacking a reproducer, there's not much we can do here, so closing.
History
Date User Action Args
2013-02-11 15:28:35r.david.murraysetstatus: open -> closed
resolution: works for me
messages: + msg181900

stage: test needed -> resolved
2012-05-24 03:05:59r.david.murraysetversions: + Python 3.3, - Python 3.1
nosy: + barry

messages: + msg161475

assignee: r.david.murray ->
components: + email, - Library (Lib)
2011-03-18 23:26:13r.david.murraysetassignee: r.david.murray
nosy: r.david.murray, raph@mankin.org.uk
2010-09-16 20:44:38eric.araujosetversions: + Python 3.1, Python 2.7, Python 3.2, - Python 2.6
2010-09-16 16:12:59r.david.murraysetmessages: + msg116569
stage: test needed
2010-09-16 15:14:16raph@mankin.org.uksetmessages: + msg116559
2010-09-16 13:58:26r.david.murraysetnosy: + r.david.murray
messages: + msg116551
2010-09-16 13:53:16raph@mankin.org.ukcreate