classification
Title: sdist includes files that are not in MANIFEST.in
Type: behavior Stage: resolved
Components: Distutils, Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Impossible to include file in sdist that starts with 'build' on Win32
View: 6884
Assigned To: tarek Nosy List: eric.araujo, nadeem.vawda, python-dev, ronaldoussoren, tarek
Priority: normal Keywords:

Created on 2010-08-26 11:30 by ronaldoussoren, last changed 2012-04-09 19:06 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
manifest-test.zip ronaldoussoren, 2010-08-26 11:30
Messages (8)
msg114966 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-08-26 11:30
The attached file 'manifest-test.zip' is a small distutils project that demonstrates a problem I have with the sdist command.

The archive contains a directory 'sandbox' that is not mentioned in MANIFEST.in or anywhere in setup.py. When I create an sdist using "python setup.py sdist" the sandbox directory is included in the archive.

This happens with 2.7 on Windows, while 2.7 on OSX does not have this behavior.
msg127864 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-02-04 03:12
Can’t reproduce on POSIX (linux2) either.  Have you tested with 3.1, 3.2 and distutils2?
msg153699 - (view) Author: Nadeem Vawda (nadeem.vawda) * (Python committer) Date: 2012-02-19 11:00
This happens because the glob-to-regexp translator assumes that the
directory separator is "/", regardless of platform. Consequently, the
regexp for "include *.py" ends up matching "sandbox\dummy.py" erroneously
on Windows.

The problem is currently being discussed in issue 6884; I'm marking this
issue as a duplicate.
msg154256 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-02-25 15:14
New changeset 47788c90f80b by Éric Araujo in branch '2.7':
Fix long-standing bugs with MANIFEST.in parsing on Windows (#6884).
http://hg.python.org/cpython/rev/47788c90f80b
msg154263 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-02-25 15:32
New changeset 73aa4c9305b3 by Éric Araujo in branch '3.2':
Fix long-standing bugs with MANIFEST.in parsing on Windows (#6884).
http://hg.python.org/cpython/rev/73aa4c9305b3
msg154458 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-02-27 11:29
New changeset 4d6a9f287543 by Éric Araujo in branch 'default':
Fix bugs with MANIFEST.in parsing on Windows (#6884).
http://hg.python.org/distutils2/rev/4d6a9f287543
msg156269 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-03-18 19:40
New changeset edcdef70c44e by Éric Araujo in branch '3.2':
Fix long-standing bugs with MANIFEST.in parsing on Windows (#6884).
http://hg.python.org/cpython/rev/edcdef70c44e
msg157880 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-04-09 19:06
New changeset b5f0ce4ddf0c by Éric Araujo in branch '2.7':
Fix long-standing bugs with MANIFEST.in parsing on Windows (#6884).
http://hg.python.org/cpython/rev/b5f0ce4ddf0c
History
Date User Action Args
2012-04-09 19:06:00python-devsetmessages: + msg157880
2012-03-18 19:40:13python-devsetmessages: + msg156269
2012-02-27 11:29:47python-devsetmessages: + msg154458
2012-02-25 15:32:26python-devsetmessages: + msg154263
2012-02-25 15:14:00python-devsetnosy: + python-dev
messages: + msg154256
2012-02-19 22:31:58eric.araujosetstatus: open -> closed
stage: test needed -> resolved
2012-02-19 11:00:57nadeem.vawdasetnosy: + nadeem.vawda
messages: + msg153699
resolution: duplicate

superseder: Impossible to include file in sdist that starts with 'build' on Win32
2011-02-04 03:12:23eric.araujosetnosy: ronaldoussoren, tarek, eric.araujo
messages: + msg127864
components: + Windows
2010-08-26 11:30:48ronaldoussorencreate