classification
Title: Regrtest failed to clean up temporary directory
Type: behavior Stage:
Components: Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test.support.unlink issue on Windows platform
View: 7443
Assigned To: Nosy List: ncoghlan, tim.golden
Priority: normal Keywords:

Created on 2010-08-17 13:24 by ncoghlan, last changed 2010-08-17 13:37 by ncoghlan. This issue is now closed.

Messages (4)
msg114120 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2010-08-17 13:24
Watching the Windows buildbot to check if test_dis was working yet, I found this output:

http://www.python.org/dev/buildbot/stable/builders/x86%20XP-4%203.x/builds/2774/steps/test/logs/stdio

It appears something still had files open in the directory when regrtest was attempting to clean it out.
msg114121 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2010-08-17 13:29
The ref count over 1 million at the end of that output is also rather
suspicious.
msg114122 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2010-08-17 13:29
This is usually because the bug mentioned in issue7443 (although it 
could be something else, obviously). It should sort itself out on the 
next run. I'll rerun on my local checkout to see if there real WinXP issues.
msg114123 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2010-08-17 13:37
Reading through the other issue, I think you're right. Closing as a duplicate of issue 7443.
History
Date User Action Args
2010-08-17 13:37:41ncoghlansetstatus: open -> closed
resolution: duplicate
superseder: test.support.unlink issue on Windows platform
messages: + msg114123
2010-08-17 13:29:29tim.goldensetnosy: + tim.golden
messages: + msg114122
2010-08-17 13:29:08ncoghlansetmessages: + msg114121
2010-08-17 13:24:57ncoghlancreate