classification
Title: typo on Mac/Makefile.in? s/pythonw/python/
Type: behavior Stage: resolved
Components: Build, macOS Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: ronaldoussoren, srid
Priority: normal Keywords:

Created on 2010-08-13 21:34 by srid, last changed 2010-09-28 14:32 by ronaldoussoren. This issue is now closed.

Messages (3)
msg113836 - (view) Author: Sridhar Ratnakumar (srid) Date: 2010-08-13 21:34
From Mac/Makefile.in:

[...]
ifneq ($(LIPO_32BIT_FLAGS),)
        lipo $(LIPO_32BIT_FLAGS) -output $(DESTDIR)$(prefix)/bin/python$(VERSION)-32 pythonw
        lipo $(LIPO_32BIT_FLAGS) -output $(DESTDIR)$(prefix)/bin/pythonw$(VERSION)-32 pythonw
        ln -sf python$(VERSION)-32 "$(DESTDIR)$(prefix)/bin/python-32"
        ln -sf pythonw$(VERSION)-32 "$(DESTDIR)$(prefix)/bin/pythonw-32"
endif
[...]

Shouldn't the last word in the first line be `python` instead of `pythonw`?

http://svn.python.org/view/python/trunk/Mac/Makefile.in?annotate=77031#l55
msg113837 - (view) Author: Sridhar Ratnakumar (srid) Date: 2010-08-13 21:35
Specifically "python$(VERSION)-32 python" instead of "python$(VERSION)-32 pythonw"?
msg117525 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-09-28 14:32
There is no typo. The python and pythonw executables are the same and are build as 'pythonw' and installed with the right name.
History
Date User Action Args
2010-09-28 14:32:29ronaldoussorensetstatus: open -> closed
versions: + Python 2.7
messages: + msg117525

resolution: not a bug
stage: resolved
2010-08-13 21:35:07sridsetmessages: + msg113837
2010-08-13 21:34:34sridcreate