classification
Title: transient crashes on "x86 XP-4" buildbot: test_file, test_file2k, test_bsddb3
Type: crash Stage:
Components: Tests, Windows Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_close_open_print_buffered(test_file) sometimes crashes
View: 9295
Assigned To: Nosy List: flox, ocean-city
Priority: normal Keywords: buildbot

Created on 2010-08-10 10:33 by flox, last changed 2010-08-10 17:26 by flox. This issue is now closed.

Messages (4)
msg113522 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-08-10 10:33
There's frequent crashes on the "x86 XP-4" buildbot.

On 2.6:
 83915: # something crashed: test_file
 83913: success
 83743: # something crashed: test_file
 83738: success
 83721: success
 83718: # something crashed: test_file
 83704: success
 83691: # something crashed: test_file
 83688: # something crashed: test_file
 83687: # something crashed: test_file
 83674: # something crashed: test_file
 83657: # something crashed: test_file
 83656: # 1 failed: test_os
 83648: # 2 failed: test_os test_struct
 83642: # something crashed: test_bsddb3
 83637: # 1 failed: test_struct
 83634: # 1 failed: test_struct
 83632: success
 83628: success
 83627: # something crashed: test_bsddb3
 83626: # something crashed: test_file
 83625: # 1 failed: test_builtin
 83624: # 1 failed: test_builtin
 83623: success
 83539: # something crashed: test_bsddb3
 83532: success
 83520: success
 83519: # something crashed: test_file
 83518: # something crashed: test_file
 83517: # something crashed: test_file
 83515: success
 83512: # something crashed: test_file
 83502: ? something crashed: test_file
 83487: success
 83443: ? exception clean
 83420: # something crashed: test_file
 83414: ? exception svn
 83382: success
 83379: # something crashed: test_file
 83377: # something crashed: test_file
 83242: success
 83200: # something crashed: test_file
 83194: success
 83147: success
 83136: # something crashed: test_file
 83128: # something crashed: test_file
 83119: success

On 2.7:
 83928: # something crashed: test_bsddb3
 83925: success
 83920: success
 83917: success
 83909: success
 83907: success
 83893: # 1 failed: test_bsddb3
 83879: success
 83873: ? exception svn
 83858: success
 83856: # something crashed: test_bsddb3
 83836: # hung for 20 min: test_file2k
 83832: # something crashed: test_file2k
 83824: ? exception svn
 83820: # something crashed: test_file2k
 83806: success
 83782: # something crashed: test_bsddb3
 83773: success
 83769: success
 83765: ? exception svn
 83760: # something crashed: test_file2k
 83757: # failed slave lost
 83749: # something crashed: test_file2k
 83746: success
 83737: # something crashed: test_bsddb3
 83734: ? exception svn

The test is interrupted on the "crash", and the last message is:
 - program finished with exit code -1073741819
   elapsedTime=184.398000
 - program finished with exit code -1073741819
   elapsedTime=383.852000
 - program finished with exit code -1073741819
   elapsedTime=1003.798000
 - program finished with exit code -1073741819
   elapsedTime=453.802000

(reports created with bbreport)
msg113523 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-08-10 10:50
IIUC code -1073741819 (0XC0000005) is an acces violation.

Some other issues with same error code: #6869, #8849, ...
msg113532 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2010-08-10 13:11
Maybe is this duplicate of #9295?
msg113550 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-08-10 17:26
Right, it looks like a duplicate.
History
Date User Action Args
2010-08-10 17:26:55floxsetstatus: open -> closed
resolution: duplicate
superseder: test_close_open_print_buffered(test_file) sometimes crashes
messages: + msg113550
2010-08-10 13:11:21ocean-citysetnosy: + ocean-city
messages: + msg113532
2010-08-10 10:54:06floxsetcomponents: + Windows
2010-08-10 10:50:22floxsetmessages: + msg113523
2010-08-10 10:33:41floxcreate