classification
Title: platform test borked in 2.7 branch on Power PC
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: janssen, ronaldoussoren
Priority: normal Keywords:

Created on 2010-08-02 19:13 by janssen, last changed 2010-08-03 08:09 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
smime.p7s ronaldoussoren, 2010-08-03 06:43
Messages (5)
msg112516 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2010-08-02 19:13
Looks like some test borked the 2.7 tests on the buildbots.  Here's the offending test:


test test_platform failed -- Traceback (most recent call last):
  File "/Users/buildbot/buildarea/2.7.parc-leopard-1/build/Lib/test/test_platform.py", line 196, in test_mac_ver
    self.assertEquals(res[2], 'PowerPC')
AssertionError: 'Power Macintosh' != 'PowerPC'

Re-running test 'test_platform' in verbose mode
test_architecture (test.test_platform.PlatformTest) ... ok
test_architecture_via_symlink (test.test_platform.PlatformTest) ... [17052 refs]
[17052 refs]
ok
test_dist (test.test_platform.PlatformTest) ... ok
test_java_ver (test.test_platform.PlatformTest) ... ok
test_libc_ver (test.test_platform.PlatformTest) ... ok
test_mac_ver (test.test_platform.PlatformTest) ... FAIL
test_mac_ver_with_fork (test.test_platform.PlatformTest) ... ok
test_machine (test.test_platform.PlatformTest) ... ok
test_node (test.test_platform.PlatformTest) ... ok
test_parse_release_file (test.test_platform.PlatformTest) ... ok
test_platform (test.test_platform.PlatformTest) ... ok
test_processor (test.test_platform.PlatformTest) ... ok
test_release (test.test_platform.PlatformTest) ... ok
test_sys_version (test.test_platform.PlatformTest) ... ok
test_system (test.test_platform.PlatformTest) ... ok
test_system_alias (test.test_platform.PlatformTest) ... ok
test_uname (test.test_platform.PlatformTest) ... ok
test_uname_win32_ARCHITEW6432 (test.test_platform.PlatformTest) ... skipped 'windows only test'
test_version (test.test_platform.PlatformTest) ... ok
test_win32_ver (test.test_platform.PlatformTest) ... ok

======================================================================
FAIL: test_mac_ver (test.test_platform.PlatformTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/2.7.parc-leopard-1/build/Lib/test/test_platform.py", line 196, in test_mac_ver
    self.assertEquals(res[2], 'PowerPC')
AssertionError: 'Power Macintosh' != 'PowerPC'

----------------------------------------------------------------------
Ran 20 tests in 6.468s

FAILED (failures=1, skipped=1)
test test_platform failed -- Traceback (most recent call last):
  File "/Users/buildbot/buildarea/2.7.parc-leopard-1/build/Lib/test/test_platform.py", line 196, in test_mac_ver
    self.assertEquals(res[2], 'PowerPC')
AssertionError: 'Power Macintosh' != 'PowerPC'
msg112528 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2010-08-02 19:46
This is on a PowerPC machine running Leopard:

>>> os.uname()[4]
'Power Macintosh'
>>>
msg112529 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2010-08-02 19:49
So the problem is in the _mac_ver_xml() routine in Lib/platform.py, which says:


    machine = os.uname()[4]
    if machine == 'ppc':
        # for compatibility with the gestalt based code
        machine = 'PowerPC'

and perhaps should say:

    machine = os.uname()[4]
    if machine in ('ppc', 'Power Macintosh'):
        # for compatibility with the gestalt based code
        machine = 'PowerPC'
msg112558 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-08-03 06:43
On 2 Aug, 2010, at 21:49, Bill Janssen wrote:

> 
> Bill Janssen <bill.janssen@gmail.com> added the comment:
> 
> So the problem is in the _mac_ver_xml() routine in Lib/platform.py, which says:
> 
> 
>    machine = os.uname()[4]
>    if machine == 'ppc':
>        # for compatibility with the gestalt based code
>        machine = 'PowerPC'
> 
> and perhaps should say:
> 
>    machine = os.uname()[4]
>    if machine in ('ppc', 'Power Macintosh'):
>        # for compatibility with the gestalt based code
>        machine = 'PowerPC'

That's correct. Thanks for catching this, I will fix this asap.

Ronald
msg112564 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-08-03 08:09
Fixed in r83644 (3.x), r83645 (3.1), r83646 (2.7), r83651 (2.6)

I'm not yet closing the issue, I want to check the buildbots later today.
History
Date User Action Args
2010-08-03 08:09:58ronaldoussorensetstatus: open -> closed
versions: + Python 2.6, Python 3.1, Python 3.2
messages: + msg112564

resolution: fixed
stage: resolved
2010-08-03 06:43:32ronaldoussorensetfiles: + smime.p7s

messages: + msg112558
2010-08-02 19:49:35janssensetmessages: + msg112529
2010-08-02 19:46:41janssensetmessages: + msg112528
2010-08-02 19:13:54janssencreate