classification
Title: glibc detected *** /usr/bin/python: corrupted double-linked list
Type: crash Stage:
Components: Interpreter Core Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mark.dickinson, nikratio
Priority: normal Keywords:

Created on 2010-08-01 16:41 by nikratio, last changed 2010-08-01 20:59 by mark.dickinson. This issue is now closed.

Files
File name Uploaded Description Edit
pylint_crasher.py nikratio, 2010-08-01 16:40
Messages (4)
msg112352 - (view) Author: Nikolaus Rath (nikratio) * Date: 2010-08-01 16:40
$ python --version
Python 2.6.5

$ pylint --version
pylint 0.21.1, 
astng 0.20.1, common 0.50.3
Python 2.6.5 (r265:79063, Apr 16 2010, 13:09:56) 
[GCC 4.4.3]

$ pylint pylint_crasher.py 
************* Module pylint_crasher
R0903: 62:Config: Too few public methods (0/2)
[....]
Global evaluation
-----------------
Your code has been rated at 7.33/10

*** glibc detected *** /usr/bin/python: corrupted double-linked list: 0x09f611d8 ***

[Program hangs here]


Since pylint seems to ship with only .py files, I suppose this has to be a bug in the Python interpreter.
msg112380 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-08-01 20:29
Is there any chance you could come up with a smaller python example that produces this crash?  Preferably one without dependencies on third-party libraries like numpy, h5py and matplotlib?  It's a bit awkward to reproduce and analyze the failure otherwise.
msg112381 - (view) Author: Nikolaus Rath (nikratio) * Date: 2010-08-01 20:32
Duplicate of http://projects.scipy.org/numpy/ticket/1462
msg112384 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-08-01 20:59
Thanks for the update!
History
Date User Action Args
2010-08-01 20:59:07mark.dickinsonsetresolution: not a bug
messages: + msg112384
2010-08-01 20:32:32nikratiosetstatus: open -> closed

messages: + msg112381
2010-08-01 20:29:25mark.dickinsonsetnosy: + mark.dickinson
messages: + msg112380
2010-08-01 16:41:01nikratiocreate