classification
Title: test_distutils fails without zlib
Type: behavior Stage: resolved
Components: Distutils Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: binbrain, eric.araujo, georg.brandl, python-dev, tarek
Priority: normal Keywords:

Created on 2010-07-31 15:36 by georg.brandl, last changed 2011-05-26 14:56 by eric.araujo. This issue is now closed.

Messages (5)
msg112157 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-07-31 15:36
Noticed it in 3.2a1, but probably present on other branches.  It should not fail, but skip these tests.
msg121716 - (view) Author: Jim Pharis (binbrain) Date: 2010-11-20 18:48
I think this is a dup of #6026 which is fixed...

svn log for Lib/distutils...

#6026: skip test_get_file_list when zlib is not available.
  this test requires zlib support
  #6026 - fix tests that failed without zlib
msg121827 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-11-21 01:21
This can be kept open as a separate report, since it was caused by the Big Distutils Revert in 3.2.  We’ve already discussed how to fix that in private email and IRC thanks to Ezio.  Because of compat requirements, we’ll probably have to use if+return instead of skipIf.
msg136970 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2011-05-26 14:55
New changeset d5572fd3b768 by Éric Araujo in branch '2.7':
Make test_distutils pass without zlib (fixes #9435)
http://hg.python.org/cpython/rev/d5572fd3b768
msg136971 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-05-26 14:56
Can’t reproduce in 3.x, fixed in 2.7.
History
Date User Action Args
2011-05-26 14:56:54eric.araujosetstatus: open -> closed
versions: + Python 2.7, - Python 3.2
messages: + msg136971

resolution: fixed
stage: needs patch -> resolved
2011-05-26 14:55:00python-devsetnosy: + python-dev
messages: + msg136970
2010-11-21 01:21:16eric.araujosetassignee: tarek -> eric.araujo
messages: + msg121827
2010-11-20 19:25:25pitrousetnosy: + eric.araujo
2010-11-20 18:48:27binbrainsetnosy: + binbrain
messages: + msg121716
2010-07-31 15:36:24georg.brandlcreate