classification
Title: argparse wrap tests are sensitive to terminal size
Type: behavior Stage: needs patch
Components: Tests Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: bethard
Priority: normal Keywords:

Created on 2010-07-23 13:14 by bethard, last changed 2010-08-10 09:46 by bethard. This issue is now closed.

Messages (3)
msg111311 - (view) Author: Steven Bethard (bethard) * (Python committer) Date: 2010-07-23 13:14
[From http://code.google.com/p/argparse/issues/detail?id=63]

What steps will reproduce the problem?
1. PYTHONPATH=. python test/test_argparse.py
2. do the above in an 80x24 terminal window and it passes
3. do the same in an 80 wide emacs shell buffer and you get lots of failures

To make sure this doesn't continue to be a problem, we probably need to do something like os.environ['COLUMNS'] = 80 and check output like that.
msg113514 - (view) Author: Steven Bethard (bethard) * (Python committer) Date: 2010-08-10 09:41
Marking as duplicate of 9553 (which has a better description and a patch).
msg113517 - (view) Author: Steven Bethard (bethard) * (Python committer) Date: 2010-08-10 09:46
Actually closing this time. Duplicate of issue 9553.
History
Date User Action Args
2010-08-10 09:46:58bethardsetstatus: open -> closed

messages: + msg113517
2010-08-10 09:41:42bethardsetresolution: duplicate
messages: + msg113514
2010-07-23 13:14:50bethardcreate