classification
Title: sysconfig module does not support -m option
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, giampaolo.rodola, tarek
Priority: normal Keywords: easy

Created on 2010-07-05 17:45 by giampaolo.rodola, last changed 2010-08-21 21:45 by eric.araujo. This issue is now closed.

Messages (6)
msg109343 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-07-05 17:45
http://docs.python.org/dev/library/sysconfig.html#using-sysconfig-as-a-script

The doc states that sysconfig module con be used with python's -m option but this doesn't work:

giampaolo@ubuntu:~/svn/python-2.7$ python -m sysconfig
giampaolo@ubuntu:~/svn/python-2.7$ 

By taking a look at the code it seems that the module doesn't contain any main() or similar function.
msg109354 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-07-05 20:57
Nice catch. I found nothing in the VCS log, nor in distutils2._backport.sysconfig, so it doesn’t seem to have been removed but just overlooked.
msg109355 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-07-05 21:10
Remove the statement from the doc for now and get it back along a module fix in 2.7.1: can it be a reasonable solution?
msg109359 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-07-05 21:57
Found: r81513 Made sysconfig a script that displays useful information - #8770
msg114569 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-21 21:44
The behavior is here in 3.2 and the doc doesn’t mention it in 2.7. Closing.
msg114570 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-21 21:45
Note that my own preference would be to have the nice behavior in 2.7 too, but since it’s not a bug fix, I think it’s just too late.
History
Date User Action Args
2010-08-21 21:45:55eric.araujosetmessages: + msg114570
2010-08-21 21:44:19eric.araujosetstatus: open -> closed
resolution: accepted -> fixed
messages: + msg114569

stage: needs patch -> resolved
2010-07-05 21:57:24eric.araujosetmessages: + msg109359
2010-07-05 21:10:43giampaolo.rodolasetmessages: + msg109355
2010-07-05 20:57:34eric.araujosetassignee: tarek
components: + Library (Lib)
type: behavior
keywords: + easy
nosy: + eric.araujo, - tarek-ziade
messages: + msg109354
resolution: accepted
stage: needs patch
2010-07-05 17:45:08giampaolo.rodolacreate