classification
Title: License for multiprocessing files
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.1, Python 3.2, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: jnoller Nosy List: FladischerMichael, asksol, daniel.tavares, eric.araujo, jnoller, r.david.murray, roudkerk, skrah
Priority: high Keywords: easy, patch

Created on 2010-07-05 06:34 by FladischerMichael, last changed 2010-12-14 01:43 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
issue9162.patch daniel.tavares, 2010-11-29 08:24
Messages (15)
msg109306 - (view) Author: Michael Fladischer (FladischerMichael) Date: 2010-07-05 06:34
The files in Lib/multiprocessing (except __init__.py) are referring to their license by point to a nonexistent file called COPYING.txt.

This possibly needs clarification as if this file is missing or the license is to be found somewhere else.
msg109316 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-07-05 11:44
Third-party code contributed to the stdlib is covered by an agreement that allows PSF to use it under PSF license. Comments in multiprocessing files can just be removed (this happened for argparse some time ago). Thanks for noticing this!
msg109318 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2010-07-05 12:09
Éric, I don't think it's that simple. The author still has the copyright,
even if he licensed the files under the contributor agreement.

At the very least you have to leave his name and copyright notice.
msg109651 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-07-09 00:44
Yes; the copyright has to stay; but the license data can leave afaik.
msg109691 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2010-07-09 08:49
[Cc: psf@python.org]

Jesse Noller <report@bugs.python.org> wrote:
> 
> Yes; the copyright has to stay; but the license data can leave afaik.

If R Oudkerk signed the agreement, replacing 'see COPYING.txt' with
'Licensed to PSF under a Contributor Agreement.' should be fine.

Does the PSF have the agreement?

Stefan Krah
msg109694 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2010-07-09 09:02
If I'm not mistaken, the original code was BSD, so in the absence of a
contributor agreement one could include the full BSD license in each
file.

http://pyprocessing.berlios.de/doc/COPYING.html
msg109712 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-07-09 11:15
Hi Stefan - I'm familiar with the license/etc of the original module. This bug isn't urgent; I shot a quick email to the PSF's secretary Pat to confirm we have a contributor agreement however.
msg109713 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2010-07-09 11:35
Jesse, there's no doubt that you know the original license. :)

I should have been more verbose: My BSD comment was intended for public
consumption. People often think GPL if they see a reference to COPYING.txt.
msg109714 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-07-09 11:37
Egad No! I gotcha. I'll find out what the deal with the contrib. agreement is. Pretty sure we had to wait on it when we brought it in.
msg116533 - (view) Author: Michael Fladischer (FladischerMichael) Date: 2010-09-16 12:15
Is there any timeline on when this will be fixed? It's currently blocking work on a python-related package for Debian.
msg116542 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-09-16 13:22
On Thu, Sep 16, 2010 at 8:15 AM, Michael Fladischer
<report@bugs.python.org> wrote:
>
> Michael Fladischer <michael@fladi.at> added the comment:
>
> Is there any timeline on when this will be fixed? It's currently blocking work on a python-related package for Debian.
>

I'll ping the PSF board for the legal recommendations again.
msg122164 - (view) Author: Daniel Tavares (daniel.tavares) Date: 2010-11-22 20:31
Hi Jesse,

Any word from PSF board regarding this issue? I was hoping to fix it and have it be my 1st contribution to Python.

Thanks
msg122167 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2010-11-22 20:47
We have to add the BSD header and maintain the copyright clause on all of the multiprocessing files. Apologies for the delay
msg122778 - (view) Author: Daniel Tavares (daniel.tavares) Date: 2010-11-29 08:24
Replaced all entries of "--- see COPYING.txt" with the BSD license. See patch attached.
msg123916 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-14 01:43
Committed in r87225, r87226, and r87227.  Thanks, Daniel.
History
Date User Action Args
2010-12-14 01:43:22r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg123916

resolution: fixed
stage: needs patch -> resolved
2010-11-29 08:24:11daniel.tavaressetfiles: + issue9162.patch
keywords: + patch
messages: + msg122778
2010-11-22 20:47:38jnollersetmessages: + msg122167
2010-11-22 20:31:27daniel.tavaressetnosy: + daniel.tavares
messages: + msg122164
2010-09-16 13:22:04jnollersetmessages: + msg116542
2010-09-16 12:15:05FladischerMichaelsetmessages: + msg116533
2010-07-09 11:37:05jnollersetmessages: + msg109714
2010-07-09 11:35:29skrahsetmessages: + msg109713
2010-07-09 11:15:20jnollersetmessages: + msg109712
2010-07-09 09:02:39skrahsetmessages: + msg109694
2010-07-09 08:49:57skrahsetmessages: + msg109691
2010-07-09 00:44:23jnollersetmessages: + msg109651
2010-07-09 00:33:44pitrousetpriority: normal -> high
assignee: jnoller

nosy: + jnoller
versions: + Python 3.1, Python 2.7, Python 3.2
2010-07-05 17:10:38skrahsetnosy: + roudkerk
resolution: accepted -> (no value)
2010-07-05 12:09:52skrahsetnosy: + skrah
messages: + msg109318
2010-07-05 11:44:52eric.araujosetnosy: + eric.araujo
messages: + msg109316

keywords: + easy
resolution: accepted
stage: needs patch
2010-07-05 06:43:57asksolsetnosy: + asksol
2010-07-05 06:34:45FladischerMichaelcreate