classification
Title: no OS X buildbots in the stable list
Type: enhancement Stage: resolved
Components: macOS Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: nobody Nosy List: eric.araujo, janssen, l0nwlf, loewis, nobody, pitrou, r.david.murray, ronaldoussoren
Priority: normal Keywords: buildbot

Created on 2010-06-21 19:25 by janssen, last changed 2010-12-14 19:11 by r.david.murray. This issue is now closed.

Messages (12)
msg108302 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2010-06-21 19:25
Considering the number of OS X machines running Python programs, it would be good idea to get this platform into the "stable" list of buildbots so that releases are checked against it.
msg108317 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-06-21 20:54
"stable" is also meant to mean "typically passes test suite without errors". I don't think OSX meets this criterion.
msg108359 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-06-22 10:40
Then why bother providing binaries?

I'm trying to keep the OSX port in good shape, but at times have to hunt down issues that were introduced by other bugfixes.

A problem with adding OSX to the list of stable buildbots is IMHO that there seem to be very few core developers that care about OSX beyond it being some odd flavor of unix.
msg108426 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-06-22 21:57
Am 22.06.2010 12:40, schrieb Ronald Oussoren:
>
> Ronald Oussoren<ronaldoussoren@mac.com>  added the comment:
>
> Then why bother providing binaries?

How is that related? There was no OSX build slave until very recently,
but binaries had been provided for years. I see no reason to stop doing
so.

 > to hunt down issues that were introduced by other bugfixes.

That's appreciated. However, I fail to see the relationship to the 
buildbot stable list. The port was in good shape, and *still* didn't
pass all tests. That's partially because the test suite tests boundary
behaviour that doesn't affect the shape of the port.

 > that there seem to be very few core developers that care about
 > OSX beyond it being some odd flavor of unix.

The problem at hand is the port *doesn't* pass the test suite on
a regular manner. If it would, it could be added, and somebody
breaking the port could be asked to revert the change, or fix it
on OSX. As it stands, changes being made cannot be easily correlated
with new failures on that platform.
msg108467 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2010-06-23 18:03
Bit of a chicken/egg issue here.  Since we haven't had OS X buildbots for very long, and the ones we do have represent odd configurations, I think it's premature to say that "the port *doesn't* pass the test suite on
a regular manner".  I think it's just as reasonable to say that the developers making changes just aren't aware of bad side-effects on OS X.  A good way to remedy that would be to make those bad side-effects more apparent, for example by adding an OS X buildbot into the "stable" set.

Another issue is that none of the three OS X buildbots now running are really good representatives of the technology that most people I know who use OS X really use.  That would be an Intel Core 2 Duo machine running Snow Leopard.
msg108471 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-06-23 18:38
> Bit of a chicken/egg issue here.  Since we haven't had OS X buildbots
> for very long, and the ones we do have represent odd configurations,
> I think it's premature to say that "the port *doesn't* pass the test
> suite on a regular manner".

And I didn't mean that literally. Rather, I meant "the build slave that 
you are proposing to add to the stable list don't pass the test suite on 
a regular manner" - it's ultimately the individual slave (OS, compiler 
installation, buildbot version, network connectivity) that can be 
questioned for stability.

So that's not really a chicken-and-egg problem. If people keep working 
on the OSX port, they might ultimately arrive in a state where even the 
odd configurations become stable.

> I think it's just as reasonable to say
> that the developers making changes just aren't aware of bad
> side-effects on OS X.  A good way to remedy that would be to make
> those bad side-effects more apparent, for example by adding an OS X
> buildbot into the "stable" set.

I am not convinced that this is a good way. First, they are all 
volunteers, so they chose to do whatever they like to do. Then, even if 
they *are* willing to fix OSX problems, they might never look at the 
buildbot results. So any estimation of the effect that the proposed 
change might have is pure guessing.
msg108484 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-06-23 20:21
Data point: on #python-dev we get announcements when buildbots (any buildbots, not just stable ones) *change state*.  That is, when a buildbot that was passing fails, or a buildbot that was failing passes.  We do look at the failures, though not all the time (if no one is around or it is one of that flaky buildbots that change state often they won't get checked or will get checked only randomly).

So, from the #python-dev perspective, the OS X buildbots will only be useful once they start being normally green.  Then we'll notice when they go red and, if we can, fix it, or open an issue.
msg108485 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-06-23 20:28
> I think it's just as reasonable to say that the developers making
> changes just aren't aware of bad side-effects on OS X.  A good way to
> remedy that would be to make those bad side-effects more apparent, for 
> example by adding an OS X buildbot into the "stable" set.

I can't speak for other developers, but I generally look into the "unstable" set when I fear one of my changes might break something (and, sure enough, some of the SSL changes I did had to be adapted so that test_ssl pass again on the OS X buildots).
msg108486 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-06-23 20:39
Martin: sorry about my first question. My interpretation of your first message was that you thought that the OSX port itself wasn't stable, and you've already mentioned that you didn't mean to imply that.

I'm unassigning the issue from my as I won't be able to actually move the osx buildbots in the stable list, at least not beyond trying to get the OSX port rock solid.

Is is possible to get e-mail about changes of buildbot status? I'd be interested in two sets of mail: any buildbot failures caused by my checkins and state changes for the OSX buildbots.

BTW. None of the buildbots currently test the configuration that is used for release builds: a 2-way or 3-way universal framework build.
msg108489 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-06-23 21:41
> Is is possible to get e-mail about changes of buildbot status? I'd be
> interested in two sets of mail: any buildbot failures caused by my
> checkins and state changes for the OSX buildbots.

Buildbot failure reports are sent to python-checkins. In theory, at 
least; I think that isn't working very well.

Sending them to individual developers might be tricky. IOW, don't expect 
to see this happen within the next months unless somebody else 
volunteers to look into the buildbot configuration.
msg108490 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-06-23 21:46
> Buildbot failure reports are sent to python-checkins. In theory, at 
> least; I think that isn't working very well.

ISTR we disabled them because there was too much churn from both
unreliable buildbots and unreliable tests, which made the noise annoying
and useless (everyone was ignoring failure notifications, I think).
msg123972 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-14 19:11
Thanks to Steven Hansen there are now OSX buildbots in the stable list.
History
Date User Action Args
2010-12-14 19:11:17r.david.murraysetstatus: open -> closed
type: enhancement
messages: + msg123972

resolution: fixed
stage: resolved
2010-06-23 21:46:15pitrousetmessages: + msg108490
2010-06-23 21:41:05loewissetmessages: + msg108489
2010-06-23 20:39:06ronaldoussorensetassignee: ronaldoussoren -> nobody

messages: + msg108486
nosy: + nobody
2010-06-23 20:28:15pitrousetnosy: + pitrou
messages: + msg108485
2010-06-23 20:21:22r.david.murraysetnosy: + r.david.murray
messages: + msg108484
2010-06-23 18:43:25belopolskysetassignee: ronaldoussoren
components: + macOS, - None
nosy: loewis, ronaldoussoren, janssen, eric.araujo, l0nwlf
2010-06-23 18:38:58loewissetmessages: + msg108471
2010-06-23 18:07:37l0nwlfsetnosy: + l0nwlf
2010-06-23 18:03:07janssensetmessages: + msg108467
2010-06-22 21:57:57loewissetmessages: + msg108426
2010-06-22 20:42:10eric.araujosetnosy: + eric.araujo
2010-06-22 10:40:20ronaldoussorensetnosy: + ronaldoussoren
messages: + msg108359
2010-06-21 20:54:44loewissetnosy: + loewis
messages: + msg108317
2010-06-21 19:26:47janssensetkeywords: + buildbot
components: + None
versions: - Python 2.7
2010-06-21 19:25:41janssencreate