classification
Title: Create PyErr_GetWindowsMessage() function
Type: Stage:
Components: Interpreter Core, Unicode, Windows Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: vstinner
Priority: normal Keywords: patch

Created on 2010-06-11 00:09 by vstinner, last changed 2011-03-02 01:07 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
pyerr_getwindowsmessage.patch vstinner, 2010-06-11 00:09
Messages (2)
msg107505 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-06-11 00:09
PyErr_SetExcFromWindowsErrWithFilenameObject() and PyErr_SetFromErrnoWithFilenameObject() have the same code to read the localized error message. The code can be factorized in a new function PyErr_GetWindowsMessage().

About the patch:
 - free s_buf just after the call to PyUnicode_FromUnicode(), don't wait until the end of the function
 - free s_buf if s_buf is not NULL and len==0. I suppose that this case is impossible, if len==0, s_buf is set to NULL or leaved unchanged (so it's also equal to NULL)

I wrote the function to raise an UnicodeDecodeError with a Windows error message.
msg129843 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-03-02 01:07
This issue doesn't solve any real issue. I prefer to close it because I don't need it anymore.
History
Date User Action Args
2011-03-02 01:07:10vstinnersetstatus: open -> closed

messages: + msg129843
resolution: not a bug
2010-06-11 00:09:14vstinnercreate