classification
Title: time module documentation differs in trunk and py3k
Type: Stage: needs patch
Components: Documentation Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: belopolsky Nosy List: belopolsky, docs@python, mark.dickinson
Priority: normal Keywords: patch

Created on 2010-06-05 15:39 by belopolsky, last changed 2010-06-08 22:05 by belopolsky. This issue is now closed.

Files
File name Uploaded Description Edit
time-doc.diff belopolsky, 2010-06-05 15:39
Messages (5)
msg107141 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-06-05 15:39
Doc/library/time.rst differs in trunk and py3k.  It appears that the trunk version is more up to date and can simply replace the py3k version, but I would like to have another pair of eyes to take a look before committing.

I also noticed that time.asctime signature is displayed as asctime([t]) and as asctime([tuple]) in docstring.  I think docstring variant is better.
msg107334 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-06-08 18:29
There seems to be a few legitimate differences such as "int or long" vs. integer, or parenthesis for print.  Patch is forthcoming.
msg107335 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-06-08 18:34
.. also 3.x does not track versionadded from 2.x
msg107336 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-06-08 18:39
r81489 should probably also be svnmerged to py3k before applying this doc change.  (As far as I can tell, this is the only outstanding unmerged trunk change.)
msg107355 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-06-08 22:05
Merged r81489 to py3k (r81840), but this affects datetime module docs, not time.  On a closer examination, the differences in time.rst are correct.
History
Date User Action Args
2010-06-08 22:05:01belopolskysetstatus: open -> closed
resolution: not a bug
messages: + msg107355
2010-06-08 18:39:05mark.dickinsonsetnosy: + mark.dickinson
messages: + msg107336
2010-06-08 18:34:08belopolskysetmessages: + msg107335
2010-06-08 18:29:12belopolskysetmessages: + msg107334
2010-06-05 15:40:26belopolskysetnosy: + docs@python
2010-06-05 15:39:06belopolskycreate