classification
Title: POP3 lib timeout
Type: Stage:
Components: Documentation Versions: Python 2.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: facundobatista, wfolta
Priority: normal Keywords:

Created on 2004-02-02 02:56 by wfolta, last changed 2008-06-21 21:07 by facundobatista. This issue is now closed.

Messages (2)
msg60461 - (view) Author: Wayne Folta (wfolta) Date: 2004-02-02 02:56
Python Library Reference 11.9 poplib - POP3

Presently says, "One exception is defined as an attribute of 
the poplib module..."

Recommend adding:

"The POP3 library is built using the socket package and 
socket exceptions are not caught by POP3."

In fact, this might be a good sentence to add to most 
Internet packages.

I needed this info to figure out how to have a POP3 
connection timeout on a message download.
msg68543 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2008-06-21 21:07
This is a standard behaviour, and you shouldn't document it in *all* the
modules.

BTW, now in the POP3 lib you already have a timeout, :)
History
Date User Action Args
2008-06-21 21:07:29facundobatistasetstatus: open -> closed
resolution: not a bug
messages: + msg68543
nosy: + facundobatista
2004-02-02 02:56:30wfoltacreate