classification
Title: configure script doesn't recognize 10.5 SDK correctly
Type: compile error Stage: resolved
Components: Build, macOS Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: mark.dickinson, ronaldoussoren
Priority: high Keywords:

Created on 2010-05-10 10:12 by ronaldoussoren, last changed 2010-05-13 07:40 by ronaldoussoren. This issue is now closed.

Messages (5)
msg105426 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-05-10 10:12
I got a build error when building the 2.7b2 installers because the MacOS module couldn't be build. That turns out to be caused by an issue in the configure script: for some reason the check for the 10.5 SDK gives the wrong answer (both with and without building using the 10.4u SDK).

I haven't had time to research the issue and worked around it by hardcoding the right answer in the configure script during my build, but that's obviously not the correct solution.
msg105430 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-05-10 11:32
I think this was fixed in r80969, but confirmation would be good.
msg105431 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-05-10 11:33
Sorry;  r81004, rather.
msg105432 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-05-10 11:39
Cool, thanks. I'll check this later this week.
msg105627 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-05-13 07:40
The issue is indeed gone in HEAD. I've also verified the other 3 active branches.
History
Date User Action Args
2010-05-13 07:40:20ronaldoussorensetstatus: open -> closed
resolution: fixed
messages: + msg105627

stage: needs patch -> resolved
2010-05-10 11:39:18ronaldoussorensetmessages: + msg105432
2010-05-10 11:33:06mark.dickinsonsetmessages: + msg105431
2010-05-10 11:32:37mark.dickinsonsetnosy: + mark.dickinson
messages: + msg105430
2010-05-10 10:12:07ronaldoussorencreate