classification
Title: lack of bdist_rpm module raises error on 'setup.py --help-commands'
Type: Stage: resolved
Components: Distutils2 Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, meatballhat, tarek
Priority: normal Keywords:

Created on 2010-05-09 01:47 by meatballhat, last changed 2010-08-14 05:54 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
distutils2-bdist-rpm-error.txt meatballhat, 2010-05-09 01:47 output from 'setup.py --help-commands'
Messages (3)
msg105361 - (view) Author: Dan Buch (meatballhat) Date: 2010-05-09 01:47
Running 'python setup.py --help-commands' in the distutils2 package raises an error because there is no 'bdist_rpm' module.  Should references to 'bdist_rpm' be removed, or should the 'bdist_rpm' module be (re?)introduced?
msg106866 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-06-01 23:17
Can you still reproduce it? I think it’s fixed by http://bitbucket.org/tarek/distutils2/changeset/19f1965a304d
msg113874 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-14 05:54
With more knowledge now, I am sure this changeset fixed this bug. Closing.
History
Date User Action Args
2010-08-14 05:54:01eric.araujosetstatus: open -> closed
resolution: fixed
messages: + msg113874

stage: resolved
2010-06-01 23:17:39eric.araujosetnosy: + eric.araujo
messages: + msg106866
2010-05-09 01:47:50meatballhatsetfiles: + distutils2-bdist-rpm-error.txt
2010-05-09 01:47:12meatballhatcreate