classification
Title: urlparse.urlunsplit should be smarter about + and file urls
Type: behavior Stage: resolved
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: orsenthil Nosy List: dabrahams, orsenthil
Priority: normal Keywords: patch

Created on 2010-05-08 04:00 by orsenthil, last changed 2010-05-08 04:08 by orsenthil. This issue is now closed.

Files
File name Uploaded Description Edit
urlparse_giturl.patch orsenthil, 2010-05-08 04:00
Messages (2)
msg105256 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-05-08 04:00
>>> from urlparse import *
>>> urlsplit('git+file:///foo/bar/baz')
SplitResult(scheme='git+file', netloc='', path='/foo/bar/baz', query='', fragment='')
>>> urlunsplit(urlsplit('git+file:///foo/bar/baz'))
'git+file:/foo/bar/baz'
>>>
msg105257 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2010-05-08 04:08
Duplicate of Issue8657
History
Date User Action Args
2010-05-08 04:08:06orsenthilsetstatus: open -> closed
resolution: duplicate
messages: + msg105257

stage: resolved
2010-05-08 04:01:01orsenthilsetnosy: + dabrahams
2010-05-08 04:00:33orsenthilcreate