classification
Title: IDLE 2.6 freezes on OS X 10.6
Type: crash Stage:
Components: IDLE, macOS Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE 2.6.1 locks up on Mac OS 10.6
View: 6864
Assigned To: ronaldoussoren Nosy List: aaron.the.cow, l0nwlf, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2010-04-12 22:48 by aaron.the.cow, last changed 2010-11-21 09:31 by ned.deily. This issue is now closed.

Messages (8)
msg102987 - (view) Author: Aaron (aaron.the.cow) Date: 2010-04-12 22:48
When ever I try to open a new window or open a saved file in the IDLE (on a mac) it freezes. I am running snow leppord on a very new mac.
msg102989 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-04-12 23:38
This is a duplicate of Issue6864.  The problem is seen with the Apple-supplied IDLE in OS X 10.6 and appears to be an interaction with IDLE 2.6 and the Apple-supplied Cocoa Tk 8.5. One workaround is to install Python 2.6.5 using the python.org OS X installer and use its IDLE which does not exhibit this problem because it is linked with Tk 8.4.  Or, if you can use Python 2.5 instead, you may be OK with Apple's built-in /usr/bin/idle2.5 .
msg103531 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-04-18 20:56
Aaron: How did you install python?
msg103618 - (view) Author: Aaron (aaron.the.cow) Date: 2010-04-19 17:42
I just used the biult in mac softwere
msg103621 - (view) Author: Shashwat Anand (l0nwlf) Date: 2010-04-19 18:50
Idle provided by built-in python in Mac OS X Snow leopard i.e. python 2.6.1  is running without any issues. It is /usr/bin/idle2.6. And if by very new mac you mean latest intel based macs released last summer, then yes I have the same machine.
msg103627 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-04-19 19:48
Shashwat: what happens when you launch /usr/bin/idle2.6 and then open a new window in it (CMD N)?  My experience is like Aaron's (and many other reports): the Apple-supplied idle2.6 in OS X 10.6 usually hangs after opening a second window, requiring a Force Quit.  The problem appears to be pretty specific to the combination of idle2.6 and the 10.6 Apple-supplied Tk 8.5.  It's not a problem with the python.org 2.6 which links to Tk 8.4.
msg103629 - (view) Author: Shashwat Anand (l0nwlf) Date: 2010-04-19 20:01
Ned : After I opened a new window, that is how it opened : http://imagebin.us/images/gbg8zdr25hviw26hnqfv.png
And IDLE hanged a little later. Had to do a force quit. So yes, the problem is in Apple build Idle2.6
msg121890 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-11-21 09:31
Consolidating with Issue6864
History
Date User Action Args
2010-11-21 09:31:31ned.deilysetstatus: open -> closed
resolution: duplicate
superseder: IDLE 2.6.1 locks up on Mac OS 10.6
messages: + msg121890
2010-04-19 20:01:59l0nwlfsetmessages: + msg103629
2010-04-19 19:48:42ned.deilysetmessages: + msg103627
2010-04-19 18:50:39l0nwlfsetnosy: + l0nwlf
messages: + msg103621
2010-04-19 17:42:45aaron.the.cowsetmessages: + msg103618
2010-04-18 20:56:59ronaldoussorensetmessages: + msg103531
2010-04-12 23:38:56ned.deilysetassignee: ronaldoussoren

components: + macOS
title: New Window Error -> IDLE 2.6 freezes on OS X 10.6
nosy: + ronaldoussoren, ned.deily
versions: + Python 2.6
messages: + msg102989
2010-04-12 22:48:47aaron.the.cowcreate