classification
Title: expat.ParserCreate - SystemError bad argument to internal function
Type: crash Stage: test needed
Components: Extension Modules, XML Versions: Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: flox, georg.brandl, vstinner
Priority: normal Keywords:

Created on 2010-03-28 08:26 by flox, last changed 2010-08-01 10:12 by flox. This issue is now closed.

Messages (3)
msg101856 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-03-28 08:26
First call gave a segfault. Following calls were successful.

Python 2.7a4+ (trunk:79443M, Mar 26 2010, 16:46:11)

~ $ python ../svnmerge.py -F -M merge -r79450,79427,79426,79425,79382,79310,79297
Traceback (most recent call last):
  File "../svnmerge.py", line 2366, in <module>
    main(sys.argv[1:])
  File "../svnmerge.py", line 2361, in main
    cmd(branch_dir, branch_props)
  File "../svnmerge.py", line 1813, in __call__
    return self.func(*args, **kwargs)
  File "../svnmerge.py", line 1483, in action_merge
    should_find_reflected(branch_dir))
  File "../svnmerge.py", line 1263, in analyze_source_revs
    return analyze_revs(branch_pathid, source_url, base, end_rev, **kwargs)
  File "../svnmerge.py", line 1215, in analyze_revs
    logs[url] = RevisionLog(url, begin, end, find_reflected)
  File "../svnmerge.py", line 535, in __init__
    split_lines=False)):
  File "../svnmerge.py", line 1034, in __getitem__
    for event, node in self._events:
  File "/opt/lib/python2.7/xml/dom/pulldom.py", line 232, in next
    rc = self.getEvent()
  File "/opt/lib/python2.7/xml/dom/pulldom.py", line 265, in getEvent
    self.parser.feed(buf)
  File "/opt/lib/python2.7/xml/sax/expatreader.py", line 198, in feed
    self.reset()
  File "/opt/lib/python2.7/xml/sax/expatreader.py", line 247, in reset
    intern=self._interning)
SystemError: Objects/methodobject.c:120: bad argument to internal function
Segmentation fault
msg112280 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-08-01 08:05
Is this somehow reproducible without svnmerge?
msg112304 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-08-01 10:12
Unable to reproduce.
History
Date User Action Args
2010-08-01 10:12:55floxsetstatus: pending -> closed

nosy: + vstinner
messages: + msg112304

resolution: works for me
2010-08-01 08:05:27georg.brandlsetstatus: open -> pending
nosy: + georg.brandl
messages: + msg112280

2010-03-28 08:26:45floxcreate