classification
Title: Interpreter crash on application shutdown
Type: crash Stage: test needed
Components: Interpreter Core, Windows Versions: Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: brian.curtin, georg.brandl, r.david.murray, roger.serwy, tb220
Priority: normal Keywords:

Created on 2010-03-25 08:50 by tb220, last changed 2013-10-13 18:32 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
cabb_appcompat.txt tb220, 2010-03-25 08:50 Error report generated by Windows
Messages (7)
msg101679 - (view) Author: (tb220) Date: 2010-03-25 08:50
Attached the error report generated by Windows. The problem occurs in 1 out of 10 shutdowns.
msg101684 - (view) Author: (tb220) Date: 2010-03-25 09:35
Please let me know how I can provide you with additional information.
msg101690 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-03-25 11:32
A recipe for reproducing the problem would be the most useful thing.  I suspect the windows error report is pretty much useless in this context.
msg101701 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-03-25 14:37
Are you running a service? I can't say I'm too familiar with the file you uploaded, but the file contains a few things that lead me to believe you may be. As David said, it would be helpful to know what you were doing.
msg101731 - (view) Author: (tb220) Date: 2010-03-25 21:06
The application consists of three processes: Process A provides a web interface to the remote user and watchdog services for process B, which A creates by using the multiprocessing module. Process B does the real work and provides a GUI to the local user. Process A communicates with process B via the xmlrpclib module. Both A and B are python processes. Process B uses the subprocess module to start process C, which is not a python process, and it communicates with it using the xmlrpclib module. Process B is the one that crashes every now and then when sys.exit is invoked.

I will try to produce the smallest possible application I can that still suffers from the problem and I will upload it.
msg165541 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-07-15 17:39
tb220, is this still a bug? Python 2.6 is now in security-fix-only mode.
msg199756 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-10-13 18:32
Closing due to lack of feedback.
History
Date User Action Args
2013-10-13 18:32:57georg.brandlsetstatus: pending -> closed

nosy: + georg.brandl
messages: + msg199756

resolution: out of date
2012-07-15 17:39:29roger.serwysetstatus: open -> pending
nosy: + roger.serwy
messages: + msg165541

2010-03-25 21:06:17tb220setmessages: + msg101731
2010-03-25 14:37:31brian.curtinsetnosy: + brian.curtin
messages: + msg101701
2010-03-25 11:32:42r.david.murraysetpriority: normal

nosy: + r.david.murray
messages: + msg101690

stage: test needed
2010-03-25 09:35:04tb220setmessages: + msg101684
2010-03-25 08:52:57tb220settype: crash
2010-03-25 08:50:56tb220create