This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: ImportError: No module named _socket
Type: Stage:
Components: None Versions: Python 2.3
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: anthonybaxter, caseyd, georg.brandl, jemfinch, loewis, sf-robot, stauffert
Priority: normal Keywords:

Created on 2003-10-01 17:21 by stauffert, last changed 2022-04-10 16:11 by admin. This issue is now closed.

Messages (10)
msg18495 - (view) Author: Peter Stauffert (stauffert) Date: 2003-10-01 17:21

There is a problem during the installation of python 2.3.1:

I used configure with the following options:
./configure --enable-shared=yes --with-signal-
module=yes --with-cxx=/usr/freeware/bin/c++

make runs to the end, only warning messages are 

Running "make test" on a SGI Origin200, IRIX 6.5-18 I 
got the following error message:
test test___all__ failed -- Traceback (most recent call 
  File "/install/fw/Python-2.Lib/test/", 
line 54, in test_all
    import _socket
ImportError: No module named _socket

This looks like the python bug 565710 reported for 
python 2.2.1 which was solved by modifications of in the top level directory.

But was modified in python 2.3.1 and I could 
not apply the old patch to the new version.

Could you help me with this problem?

Thanks a lot

Peter Stauffert
msg18496 - (view) Author: casey dunn (caseyd) Date: 2003-10-01 19:53
Logged In: YES 

I have seen this on Solaris as well, recent and old vintages.

Casey Dunn
msg18497 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2003-10-03 13:28
Logged In: YES 

Can you please attach the build log? In particular, it would
be importing to see whether building _socket was attempted,
and failed.

Maybe your compiler just doesn't work???
msg18498 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2003-10-04 00:24
Logged In: YES 

Does the patch available from fix
this problem?

Which compiler did you use? From the configure line, above,
it looks like you might be using gcc?
msg18499 - (view) Author: Jeremy Fincher (jemfinch) Date: 2003-10-11 11:35
Logged In: YES 

I have this same bug on Solaris 7 with 2.3.2.
msg18500 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2003-10-13 05:51
Logged In: YES 

Works for me on Solaris 2.6, 7 and 8. What compiler, what
version, what error did you get during the build of
msg18501 - (view) Author: Jeremy Fincher (jemfinch) Date: 2003-10-13 14:33
Logged In: YES 

If you don't mind, I'll just link you to my comp.lang.python
post about it:">

That has the exact compilation error.  I've tried passing
the --disable-IPV6 option to configure (as MvL mentioned)
and it seemed to compile, but I still don't have access to
the _socket library, probably due to the second error I
mentioned.  I tried the fix in the bug #565710 (adding
runtime_library_dirs to but to no avail.
msg18502 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2003-10-13 21:27
Logged In: YES 

jemfinch, I very much doubt that you have the same problem
as the submitter of this report, and your Usenet message
gives hardly enough detail to analyse the problem; for
example, the linker error you report has a truncated error
message. Please submit a separate report, and report
precisely what you did, the complete output that you got,
and what exactly isn't working the way you expect it to work.
msg18503 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2006-02-20 19:33
Logged In: YES 

OP: Do you still experience problems with 2.4?
msg18504 - (view) Author: SourceForge Robot (sf-robot) Date: 2006-03-07 03:28
Logged In: YES 

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).
Date User Action Args
2022-04-10 16:11:32adminsetgithub: 39348
2003-10-01 17:21:24stauffertcreate