classification
Title: IDLE(Python GUI) Doesn't open
Type: crash Stage:
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Estroms, brian.curtin, loewis
Priority: normal Keywords:

Created on 2010-03-09 16:10 by Estroms, last changed 2010-03-11 15:54 by loewis. This issue is now closed.

Messages (9)
msg100734 - (view) Author: (Estroms) Date: 2010-03-09 16:10
I downloaded Python 3.1 yesterday. I can open the Python command line, but when i press IDLE(Python GUI)shortcut no window or program opens.

i typed to command promt C:\Python31\lib\idlelib\idle.py and got an error message. It's too long to write to here, but in the end of it, it said that "This probably means that Tcl wasn't installed properly". What should I do?
msg100741 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-03-09 20:22
> What should I do?

Unset the the TCL_LIBRARY and TK_LIBRARY environment variables, and
report whether it helped.
msg100780 - (view) Author: (Estroms) Date: 2010-03-10 12:20
I'm beginner, so where can I find those things?
msg100786 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-03-10 14:18
In a command prompt window, type the following:

C:\>set TCL_LIBRARY=
C:\>set TK_LIBRARY=
C:\>C:\Python31\python.exe C:\Python31\Lib\idlelib\idle.py
msg100853 - (view) Author: (Estroms) Date: 2010-03-11 14:03
When I write to Command Promt "C:\>set TCL_LIBRARY=" it says: "'C:\' is not recognized as an internal or external command, operable program or batch file."
msg100855 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-03-11 14:07
That was an example of the cmd prompt. 
Just type "set TCL_LIBRARY=" without the quotes, along with the contents of the other three lines except for the "C:\>".
msg100865 - (view) Author: (Estroms) Date: 2010-03-11 15:24
When I type "set TCL_LIBRARY" it says "TCL_LIBRARY=C:IBMTOOLS\Python22\tcl\tcl18.4".
So I have older version of python on my computer in IBMtools, but I want to use the new Python. How can I uninstall older python, because it can't be found in Start menu and there is no uninstall program in python folder. So how can I uninstall it using command prompt?
msg100866 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2010-03-11 15:33
Just delete the Python22 folder.

Typing "set TCL_LIBRARY=" (note the equal sign) will unset the environment variable for that command prompt. Can you try running the steps from msg100786?
msg100870 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-03-11 15:54
I recommend against deleting that Python installation: it probably came from the PC vendor, and might serve a purpose.

Just unset TCL_LIBRARY, through the Windows Environment GUI. Ask on comp.lang.python how to do this, or on some Windows help forum.
History
Date User Action Args
2010-03-11 15:54:50loewissetstatus: open -> closed
resolution: not a bug
messages: + msg100870
2010-03-11 15:33:00brian.curtinsetmessages: + msg100866
2010-03-11 15:24:28Estromssetmessages: + msg100865
2010-03-11 14:07:37brian.curtinsetmessages: + msg100855
2010-03-11 14:03:10Estromssetmessages: + msg100853
2010-03-10 14:18:09brian.curtinsetnosy: + brian.curtin
messages: + msg100786
2010-03-10 12:20:25Estromssetmessages: + msg100780
2010-03-09 20:22:13loewissetnosy: + loewis
messages: + msg100741
2010-03-09 16:10:35Estromscreate