classification
Title: TypeError at the end of 'make test'
Type: behavior Stage: resolved
Components: Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: subprocess.Popen.__del__ causes AttributeError (os module == None)
View: 5099
Assigned To: Nosy List: barry, pitrou
Priority: normal Keywords:

Created on 2010-03-08 22:08 by barry, last changed 2010-03-09 10:33 by flox. This issue is now closed.

Messages (5)
msg100674 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-03-08 22:08
'make test' on Ubuntu 10.04 alpha produces:

328 tests OK.
1 test failed:
    test_readline
37 tests skipped:
    test_aepack test_al test_applesingle test_bsddb test_bsddb185
    test_bsddb3 test_cd test_cl test_codecmaps_cn test_codecmaps_hk
    test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
    test_dl test_gl test_imageop test_imgfile test_kqueue
    test_linuxaudiodev test_macos test_macostools test_normalization
    test_ossaudiodev test_pep277 test_py3kwarn test_scriptpackages
    test_smtpnet test_socketserver test_startfile test_sunaudiodev
    test_timeout test_urllib2net test_urllibnet test_winreg
    test_winsound test_zipfile64
1 skip unexpected on linux2:
    test_bsddb
Exception TypeError: TypeError("'NoneType' object is not callable",) in <bound method Popen.__del__ of <subprocess.Popen object at 0x5d63650>> ignored
make: *** [test] Error 1

The readline failure is reported elsewhere.  It's the TypeError at the end that's the problem here.  I think this does not happen on Ubuntu 9.10.
msg100675 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-03-08 22:44
<flox> barry, Taggnostr: all the tests using subprocess  [17:42]
<flox> "test_bz2 test_cmd_line test_platform test_popen2 test_popen test_pydoc
       test_quopri test_signal test_subprocess test_sys test_threading
       test_unicodedata test_winsound"
<flox> you may test with this list as parameter, then shorten the list to find
       the culprit  [17:43]
<flox> (if it is repeatable)
msg100676 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-03-08 22:45
Does not error on Ubuntu 9.10 as far as I can tell.  Seems to be only 10.04 (alpha) for some reason.  I've only tested on 64 bit.

This is probably not a release blocker.
msg100689 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-03-09 01:39
Probably a duplicate of issue5099.
msg100694 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-03-09 02:27
Not a release blocker.
History
Date User Action Args
2010-03-09 10:33:49floxsetstatus: open -> closed
2010-03-09 10:33:27floxsetstatus: pending -> open
resolution: duplicate
2010-03-09 10:33:13floxsetstatus: open -> pending
type: behavior
superseder: subprocess.Popen.__del__ causes AttributeError (os module == None)
stage: resolved
2010-03-09 02:27:27barrysetpriority: release blocker -> normal

messages: + msg100694
2010-03-09 01:39:28pitrousetnosy: + pitrou
messages: + msg100689
2010-03-08 22:45:06barrysetmessages: + msg100676
2010-03-08 22:44:00barrysetmessages: + msg100675
2010-03-08 22:08:13barrycreate