classification
Title: too aggressive dependency tracking in distutils
Type: behavior Stage: resolved
Components: Distutils Versions:
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, ronaldoussoren, tarek
Priority: normal Keywords:

Created on 2010-02-09 18:55 by ronaldoussoren, last changed 2014-03-13 20:48 by eric.araujo. This issue is now closed.

Messages (4)
msg99135 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2010-02-09 18:55
build_ext calculates which files for an Extension need to be recompiled. This calculation is way to aggrasive: if any source file for an Extension has changed all source files get recompiled.

It would be nice if distutils would only recompile the sources that actually changed (taking into account the 'depends' attribute of the Extension). 

If I read the code correctly this would be a new version, it seems that the current behavior is intentional.
msg113020 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-05 19:12
With development of disutils2, distutils issues are not getting much separate attention. This may or may not get folded in to disutils2.
msg115779 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-09-07 15:33
I understand this is not a bug but a nicety/performance issue, so I’m reassigning to distutils2.
msg213467 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2014-03-13 20:48
See #14517 and #5372.
History
Date User Action Args
2014-03-13 20:48:16eric.araujosetstatus: open -> closed
versions: - 3rd party
messages: + msg213467

components: + Distutils, - Distutils2
resolution: rejected
stage: needs patch -> resolved
2010-09-29 23:53:51eric.araujosetversions: + 3rd party, - Python 2.6, Python 2.5, Python 3.1, Python 2.7, Python 3.2
2010-09-07 15:49:05terry.reedysetnosy: - terry.reedy
2010-09-07 15:33:46eric.araujosetversions: + Python 2.6, Python 2.5, Python 3.1
nosy: + eric.araujo

messages: + msg115779

components: - Distutils
2010-08-06 05:55:48baijumsetnosy: terry.reedy, ronaldoussoren, tarek
components: + Distutils2
2010-08-05 19:12:43terry.reedysetnosy: + terry.reedy
messages: + msg113020
2010-02-09 18:55:23ronaldoussorencreate