classification
Title: Python 3.1.1 source build issues
Type: compile error Stage:
Components: Build Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, loewis, sharmaag
Priority: normal Keywords:

Created on 2009-12-28 14:25 by sharmaag, last changed 2009-12-28 14:49 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
sqlite-source-3_5_9.zip sharmaag, 2009-12-28 14:25 sqlite-3.5.9 source
Messages (3)
msg96947 - (view) Author: Anurag (sharmaag) Date: 2009-12-28 14:25
Hi

I downloaded the source for Python-3.1.1 for windows x86. I followed the
instructions in the PCbuild\Readme.txt file to build python

Basically, all I did was
1.	Open the “PCbuild\pcbuild.sln” in VS2008.
2.	Select the “Win32” as Solution Platform and “Release” as Solution
Configuration
3.	Build Solution (F6)

I got the following error messages
Error      1              fatal error C1083: Cannot open source file:
'..\..\sqlite-3.5.9\sqlite3.c': No such file or directory   c1         
      sqlite3
Error      11           fatal error C1083: Cannot open include file:
'bzlib.h': No such file or directory      
Desktop\Python-3.1.1__\Python-3.1.1\Modules\bz2module.c     12           bz2
Error      12           fatal error C1083: Cannot open include file:
'tcl.h': No such file or directory          
Desktop\Python-3.1.1__\Python-3.1.1\Modules\_tkinter.c           66    
      _tkinter
Error      13           fatal error C1083: Cannot open include file:
'tcl.h': No such file or directory          
Desktop\Python-3.1.1__\Python-3.1.1\Modules\tkappinit.c          16    
      _tkinter
Error      14           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      15           error PRJ0019: A tool returned an error code
from "Performing Pre-Build Event..."           _ssl        _ssl
Error      16           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      17           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      18           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      19           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      20           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      21           fatal error C1083: Cannot open include file:
'sqlite3.h': No such file or directory  
desktop\python-3.1.1__\python-3.1.1\modules\_sqlite\connection.h     33
          _sqlite3
Error      23           error PRJ0019: A tool returned an error code
from "Performing Pre-Build Event..."           _hashlib               
_hashlib



To fix the missing sqllite code issue, I did the following
1. I created a folder named "sqlite-3.5.9" under "Modules". 
2. I downloaded the code for sqlite-3.5.9 (This code is attached). 
3. I copied the downlaoded code for sqlite-3.5.9 under the following
directory
Desktop\Python-3.1.1\Python-3.1.1\Modules\sqlite-3.5.9
4. From the newly copied files, I copied the "sqlite3.h" file to the
following folder
Desktop\Python-3.1.1\Python-3.1.1\Modules\_sqlite

After this I tried cleaned and build again.

Errors reduced. I got the following errors this time.

Error	1	fatal error C1083: Cannot open source file:
'..\..\sqlite-3.5.9\sqlite3.c': No such file or directory	c1	sqlite3
Error	2	fatal error C1083: Cannot open include file: 'bzlib.h': No such
file or directory
Desktop\Python-3.1.1\Python-3.1.1\Modules\bz2module.c	12	bz2
Error	3	fatal error C1083: Cannot open include file: 'tcl.h': No such
file or directory
Desktop\Python-3.1.1\Python-3.1.1\Modules\_tkinter.c	66	_tkinter
Error	4	fatal error C1083: Cannot open include file: 'tcl.h': No such
file or directory
Desktop\Python-3.1.1\Python-3.1.1\Modules\tkappinit.c	16	_tkinter
Error	5	error PRJ0019: A tool returned an error code from "Performing
Pre-Build Event..."	_ssl	_ssl
Error	6	fatal error LNK1181: cannot open input file '.\sqlite3.lib'
_sqlite3	_sqlite3
Error	7	error PRJ0019: A tool returned an error code from "Performing
Pre-Build Event..."	_hashlib	_hashlib


Can someone help me fix these errors.

Thanks in advance


Thanks
Anurag
msg96949 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-12-28 14:41
The purpose of this bug tracker is not to obtain help, but to report
bugs etc.

See PCbuild/readme.txt for detailed instructions.
msg96951 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-12-28 14:49
To the poster's defense, the paragraph mentioning "external.bat" is
below the list of the external projects.
History
Date User Action Args
2009-12-28 14:49:45amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg96951
2009-12-28 14:41:38loewissetstatus: open -> closed

nosy: + loewis
messages: + msg96949

resolution: not a bug
2009-12-28 14:25:55sharmaagcreate