classification
Title: incomplete doc of zlib
Type: Stage:
Components: Documentation Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Odd behaviour with zlib.decompressobj optional parameter "wbits"
View: 7191
Assigned To: georg.brandl Nosy List: amaury.forgeotdarc, coolwanglu, georg.brandl
Priority: normal Keywords:

Created on 2009-12-27 11:43 by coolwanglu, last changed 2009-12-27 20:46 by amaury.forgeotdarc. This issue is now closed.

Messages (3)
msg96906 - (view) Author: WANG Lu (coolwanglu) Date: 2009-12-27 11:43
Python version: 2.6.4 r264:75706 (ubuntu 9.10)

I'm working on zlib, and have been busy in finding a way of specify the
window size of compression.

After wasting minutes in python online doc, I google and find the way:

zlib.compressobj(level, method, window_size, mem_level)

However, in both online doc and build-in doc, only the first parameter
'level' is mentioned. This is too bad.

And I wonder if there are more missing ones.
msg96907 - (view) Author: WANG Lu (coolwanglu) Date: 2009-12-27 12:00
Oh I found this is mentioned in
msg94409(http://bugs.python.org/issue7191#msg94409)
msg96923 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-12-27 20:46
Closing as duplicate of issue7191
History
Date User Action Args
2009-12-27 20:46:55amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg96923

superseder: Odd behaviour with zlib.decompressobj optional parameter "wbits"
resolution: duplicate
2009-12-27 12:00:38coolwanglusetmessages: + msg96907
2009-12-27 11:43:45coolwanglucreate