classification
Title: python does not work in command prompt
Type: crash Stage: resolved
Components: Windows Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, brett.cannon, memol_jpn, r.david.murray
Priority: normal Keywords:

Created on 2009-12-13 20:35 by memol_jpn, last changed 2009-12-13 22:16 by r.david.murray. This issue is now closed.

Messages (4)
msg96351 - (view) Author: mohammad (memol_jpn) Date: 2009-12-13 20:35
when i type python in my command promp this message is shown :

C:\Documents and Settings\X>python
Fatal Python error: Py_Initialize: can't initialize sys standard streams
LookupError: unknown encoding: cp720

This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application's support team for more information.

what's the problem ?!
msg96357 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2009-12-13 21:21
Your OS is using an encoding called cp720 which Python knows nothing 
about. That means it can't open stdout, stderr, or stdin properly for 
reading/writing according to your set codec. You need to use a codec 
recognized by Python or add support for your codec to allow it to run.
msg96361 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2009-12-13 22:14
See #1616979.
msg96362 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-12-13 22:16
As Benjamin points out, this is a duplicate of issue 1616979, which has
been fixed in both trunk and py3k.  For future reference, Mohammad, a
search with the string 'cp720' and 'status' set to 'don't care' would
have brought up that bug report.  The tracker's default of searching
only open bugs can be misleading if you don't notice it.
History
Date User Action Args
2009-12-13 22:16:24r.david.murraysetpriority: normal

nosy: + r.david.murray
messages: + msg96362

resolution: not a bug -> duplicate
stage: resolved
2009-12-13 22:14:08benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg96361
2009-12-13 21:21:46brett.cannonsetstatus: open -> closed

nosy: + brett.cannon
messages: + msg96357

resolution: not a bug
2009-12-13 20:35:46memol_jpncreate