classification
Title: doc: Code is not always colored
Type: behavior Stage:
Components: Documentation Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: ezio.melotti, flox, georg.brandl
Priority: normal Keywords:

Created on 2009-12-12 20:43 by flox, last changed 2009-12-30 18:33 by georg.brandl. This issue is now closed.

Messages (5)
msg96306 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2009-12-12 20:43
Some code samples are not syntax colored in the doc for Python 3.
In the documentation for Python 2, it is OK.

Example:
  http://docs.python.org/dev/py3k/library/stdtypes.html#methods
  http://docs.python.org/dev/library/stdtypes.html#methods
msg96307 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2009-12-12 20:46
The bug seems related to Sphynx on Python3.

These examples are NOT colored::

  class Z:
    def __init__(self):
      pass

::

  class F:
    def __foo__(self):
      pass

::

  class C:
      def method(self):
          pass

  c = C()
  c.method.__func__.whoami = 'my name is c'



While these examples are colored correctly::

  class A:
    pass

  class B:
    def b(self):
      pass

  class C(): pass
msg97036 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-12-30 16:22
This was caused by an old version of Pygments being used for building
the docs; I installed a new one in the external repo in r77144.
msg97047 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2009-12-30 17:34
Thank you.

Doc/README.txt and Doc/make.bat need update too.


Note: issue7602 is a follow up regarding the *make clean* and *make
update* commands.
msg97048 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-12-30 18:33
Fixed in r77151.
History
Date User Action Args
2009-12-30 18:33:34georg.brandlsetstatus: open -> closed

messages: + msg97048
2009-12-30 17:34:58floxsetstatus: closed -> open

messages: + msg97047
2009-12-30 16:22:11georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg97036
2009-12-30 15:55:23ezio.melottisetpriority: normal
nosy: + ezio.melotti
type: behavior
2009-12-12 20:46:34floxsetmessages: + msg96307
2009-12-12 20:43:37floxcreate