classification
Title: Solaris SPARC: _multiprocessing.so: symbol sem_timedwait: referenced symbol not found
Type: compile error Stage:
Components: Build, Library (Lib) Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: jnoller Nosy List: jnoller, loewis, srid
Priority: normal Keywords:

Created on 2009-12-08 00:12 by srid, last changed 2010-01-12 02:39 by srid. This issue is now closed.

Files
File name Uploaded Description Edit
config.log srid, 2009-12-08 00:12
pyconfig.h srid, 2009-12-08 23:42
Messages (3)
msg96094 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-12-08 00:12
[...]
cc -xcode=pic32 -DNDEBUG -O -DHAVE_SEM_TIMEDWAIT=0 -
IModules/_multiprocessing -I. -I./Include -IInclude -
I/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-solaris8-
sparc-apy27-rrun/python -c /export/home/apy/rrun/build/activepython-
DEV/build/py2_7a1-solaris8-sparc-apy27-
rrun/python/Modules/_multiprocessing/semaphore.c -o build/temp.solaris-
2.8-sun4u-2.7/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-
solaris8-sparc-apy27-rrun/python/Modules/_multiprocessing/semaphore.o
"/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-solaris8-
sparc-apy27-rrun/python/Modules/_multiprocessing/semaphore.c", line 318: 
warning: implicit function declaration: sem_timedwait
cc -G build/temp.solaris-2.8-sun4u-
2.7/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-solaris8-
sparc-apy27-rrun/python/Modules/_multiprocessing/multiprocessing.o 
build/temp.solaris-2.8-sun4u-
2.7/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-solaris8-
sparc-apy27-rrun/python/Modules/_multiprocessing/socket_connection.o 
build/temp.solaris-2.8-sun4u-
2.7/export/home/apy/rrun/build/activepython-DEV/build/py2_7a1-solaris8-
sparc-apy27-rrun/python/Modules/_multiprocessing/semaphore.o -o 
build/lib.solaris-2.8-sun4u-2.7/_multiprocessing.so
*** WARNING: renaming "_multiprocessing" since importing it failed: 
ld.so.1: python: fatal: relocation error: file build/lib.solaris-2.8-
sun4u-2.7/_multiprocessing.so: symbol sem_timedwait: referenced symbol 
not found

$ uname -a
SunOS nail 5.8 Generic_117350-55 sun4u sparc SUNW,Sun-Fire-280R
msg96162 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-12-09 00:05
After ./configure step, I made the following changes to pyconfig.h in 
order to fix this issue:

$ diff  pyconfig.h.orig pyconfig.h
561c561
< /* #undef HAVE_SEM_TIMEDWAIT */
---
> #undef HAVE_SEM_TIMEDWAIT

Ideally, something needs to be changed in configure.in I believe. 

It seems that this bug was introduced in r71009. Any idea Jesse/Martin?
msg97618 - (view) Author: Sridhar Ratnakumar (srid) Date: 2010-01-12 02:39
Found the root cause: it was introduced by a patch (to fix the same issue in the past) committed by us.
History
Date User Action Args
2010-01-12 02:39:38sridsetstatus: open -> closed

messages: + msg97618
2009-12-09 00:05:59sridsetnosy: + loewis
messages: + msg96162
2009-12-08 23:43:01sridsetfiles: + pyconfig.h
2009-12-08 00:41:51pitrousetpriority: normal
assignee: jnoller

nosy: + jnoller
versions: + Python 2.6, Python 3.1, Python 3.2
2009-12-08 00:12:38sridcreate