classification
Title: test_multiprocessing leaks
Type: resource usage Stage: needs patch
Components: Library (Lib), Tests Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: jnoller Nosy List: jnoller, pitrou, r.david.murray
Priority: high Keywords:

Created on 2009-11-23 19:39 by pitrou, last changed 2009-11-24 15:25 by r.david.murray. This issue is now closed.

Messages (7)
msg95649 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-11-23 19:39
This has started a few days ago. I don't know if this was triggered by a
multiprocessing change or an unrelated one.
On trunk:

test_multiprocessing
beginning 6 repetitions
123456
......
test_multiprocessing leaked [277, 277, 277] references, sum=831

On py3k:

test_multiprocessing
beginning 6 repetitions
123456
......
test_multiprocessing leaked [229, 229, 229] references, sum=687
msg95656 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2009-11-23 20:25
AFAIK; I haven't changed anything which would introduce refleaks in the 
code. So, it's going to be a matter of chasing down all of the changes 
since the refleaks popped up and see which one triggered it.
msg95663 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-11-24 03:04
This started just after r76438, which is an additional test for
multiprocessing.  Given build delays this is only a correlation not a
definite cause, but it is suspicious.
msg95674 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-11-24 12:56
> R. David Murray <rdmurray@bitdance.com> added the comment:
> 
> This started just after r76438, which is an additional test for
> multiprocessing.  Given build delays this is only a correlation not a
> definite cause, but it is suspicious.

I just checked, it was indeed introduced by r76438.
msg95675 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2009-11-24 14:14
Well, that's alarming. I'll back that out for now - I'm fairly disturbed 
it introduced leaks that bad.
msg95678 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2009-11-24 14:22
I've backed it out on trunk and py3k. I've reopened the original bug to 
debug the refleak caused by the test.
msg95683 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-11-24 15:25
I haven't looked at the test, but is it possible that the logging module
is creating state that isn't being cleaned up after the test completes?
 Test refleaks don't always mean refleaks in the underlying C code.
History
Date User Action Args
2009-11-24 15:25:54r.david.murraysetmessages: + msg95683
2009-11-24 14:22:55jnollersetstatus: open -> closed
resolution: fixed
messages: + msg95678
2009-11-24 14:14:12jnollersetmessages: + msg95675
2009-11-24 12:56:09pitrousetmessages: + msg95674
2009-11-24 03:04:35r.david.murraysetnosy: + r.david.murray
messages: + msg95663
2009-11-23 20:25:09jnollersetmessages: + msg95656
2009-11-23 19:39:20pitroucreate