classification
Title: Windows 64-bit build "skips" several projects in VS 2008
Type: behavior Stage:
Components: Build, Windows Versions: Python 2.6
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: loewis, srid
Priority: normal Keywords:

Created on 2009-11-20 21:24 by srid, last changed 2009-11-25 23:16 by srid. This issue is now closed.

Files
File name Uploaded Description Edit
py264-xp64bit-vs2008-buildlog.txt srid, 2009-11-20 21:24 VS2008 on WinXP x64 - building Python 2.6.4
Messages (5)
msg95565 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-11-20 21:24
1. Install Windows 64-bit (SP2)
2. Install Visual Studio 2008 Professional w/ 64-bit components
3. Download Python-2.6.4.tgz
4. Open PCbuild/pcbuild.sln
5. Select "Release" and "x64" in the configuration toolbar

One would notice that only the projects "make_buildinfo" and 
"make_versioninfo" are built (which too as Win32, not x64 - for unknown 
reason). All projects are *skipped*. I don't know why. 

64-bit build would work on a 32-bit Windows machine (cross-
compilation), but not a native 64-bit Windows machine?

Attached is the Visual Studio build log.
msg95566 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-11-20 21:25
> All projects are *skipped*.

I meant: All other projects are *skipped*.
msg95630 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-11-23 14:23
I can't reproduce this. If I do your steps 1 to 5, *nothing* is build -
not surprisingly, since these steps don't invoke a build at all.

When I then select, in the context menu of "Solution 'pcbuild'", the
menu item "Build solution", it builds everything.

Also, what operating system is "Windows 64-bit (SP2)"?
msg95638 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-11-23 17:05
[...]
Step 6. Build Solution

The OS was 64-bit Windows XP (w/ Service Pack 2). Are you sure you were 
running a 64-bit operating system (i.e., not cross-compiling)?
msg95727 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-11-25 23:16
Ok, I found that this issue happens only with RTM version of VS2008. 
The fix is to install SP1. 

ref - http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/
beb4abe5-b40c-4008-aac4-343f3493e5ba
History
Date User Action Args
2009-11-25 23:16:04sridsetstatus: open -> closed

messages: + msg95727
2009-11-23 17:05:50sridsetmessages: + msg95638
2009-11-23 14:23:44loewissetnosy: + loewis
messages: + msg95630
2009-11-20 21:25:29sridsetmessages: + msg95566
2009-11-20 21:24:06sridcreate