classification
Title: Command line testing consistency between 2.x and 3.x
Type: behavior Stage:
Components: Tests Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: ncoghlan Nosy List: dstanek, eric.araujo, ncoghlan
Priority: low Keywords: easy

Created on 2009-11-16 06:14 by ncoghlan, last changed 2010-08-01 01:11 by ncoghlan. This issue is now closed.

Messages (3)
msg95322 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2009-11-16 06:14
I ran into a few gratuitous conflicts forward porting the command line
testing cleanup. This should be eliminated by making script_helper
sufficiently flexible to cover both the 2.x and 3.x use cases.
msg112232 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2010-07-31 23:51
Is this outdated now that 2.7 is out?

If not, could you give some details so that someone looking for issues tagged easy can have a go at a patch?
msg112246 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2010-08-01 01:11
Not worth it - I only had problems with it because I was doing a fairly significant refactor of the command line testing at one point.

With 2.7 out, any changes to these tests on that branch are going to be pretty minor so the incompatibilities shouldn't cause major issues for forward porting.
History
Date User Action Args
2010-08-01 01:11:15ncoghlansetstatus: open -> closed
resolution: wont fix
messages: + msg112246
2010-07-31 23:51:51eric.araujosetnosy: + eric.araujo
messages: + msg112232
2010-07-31 18:26:02dstaneksetnosy: + dstanek
2009-11-16 06:59:02ncoghlansetpriority: normal -> low
2009-11-16 06:14:53ncoghlancreate