classification
Title: buildbot occasional DBFileExistsError failures in test_bsddb3
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ezio.melotti Nosy List: amaury.forgeotdarc, ezio.melotti, flox, jcea, r.david.murray
Priority: normal Keywords: buildbot, patch

Created on 2009-11-06 02:58 by r.david.murray, last changed 2010-01-24 21:51 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
issue7269_bsddb3.diff flox, 2010-01-15 15:59 Patch, apply to trunk
Messages (5)
msg94962 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2009-11-06 02:58
The windows buildbot occasionally fails with tracebacks like this:

======================================================================
ERROR: test01_badpointer (bsddb.test.test_misc.MiscTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File
"E:\cygwin\home\db3l\buildarea\2.6.bolen-windows\build\lib\bsddb\test\test_misc.py",
line 21, in test01_badpointer
    dbs = dbshelve.open(self.filename)
  File
"E:\cygwin\home\db3l\buildarea\2.6.bolen-windows\build\lib\bsddb\dbshelve.py",
line 106, in open
    d.open(filename, dbname, filetype, flags, mode)
  File
"E:\cygwin\home\db3l\buildarea\2.6.bolen-windows\build\lib\bsddb\dbshelve.py",
line 171, in open
    self.db.open(*args, **kwargs)
DBFileExistsError: (17, 'File exists -- __fop_file_setup:  Retry limit
(100) exceeded')

This also happens for several of the other test methods.
msg94970 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-11-06 14:17
Unless I am mistaken, self.filename has no path, and files are created
in the current directory...
msg97818 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-01-15 15:59
#7691 marked duplicate of this bug.

I've set the current directory read-only to track this bug.

There's a single TestCase which creates the file in the current directory instead of /tmp. All other bsddb tests use either "get_new_environment_path" or "get_new_database_path".
msg98243 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-01-24 17:34
It may occur on any platform.
The patch fixes the issue.
msg98252 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2010-01-24 21:51
Fixed in r77733 (trunk) and r77734 (release26-maint), thanks for the patch!
History
Date User Action Args
2010-01-24 21:51:42ezio.melottisetstatus: open -> closed

assignee: jcea -> ezio.melotti

nosy: + ezio.melotti
messages: + msg98252
resolution: fixed
stage: patch review -> resolved
2010-01-24 17:34:27floxsetmessages: + msg98243
title: Windows buildbot occasional DBFileExistsError failures in test_bsddb3 -> buildbot occasional DBFileExistsError failures in test_bsddb3
2010-01-15 15:59:08floxsetfiles: + issue7269_bsddb3.diff

nosy: + flox
messages: + msg97818

keywords: + patch
stage: needs patch -> patch review
2010-01-15 15:53:22floxlinkissue7691 superseder
2009-11-06 14:17:17amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg94970
2009-11-06 02:58:51r.david.murraycreate